domingo, 7 de marzo de 2010

Elementos duplicados en campos distintos.

Descubriremos cómo podemos trabajar sobre valores duplicados en distintos campos:
...tengo un archivo con 3 columnas en la primera columna tengo codigos numericos en la segunda descripciones y en la tercera codigos numericos. Lo que quiero es ver que codigos de la columna 3 coinciden con los de la columna 1 y asociarle la descripcion (columna 2)...

En una entrada anterior vimos cómo podíamos configurar un Formato condicional con fórmula para descubrir que registros se repetían; de manera similar trabajaremos ahora.
En primer lugar Asignaremos nombres a los distintos rangos, empleándolos después en nuestra función CONTAR.SI.
Nuestra base de datos es:

Elementos duplicados en campos distintos.


Nuestros rangos serán entonces:
cód1 =Hoja1!$A$2:$A$6
cód2 =Hoja1!$C$2:$C$6
El siguiente paso será aplicar un Formato condicional con la siguiente fórmula (ver duplicados con formato condicional):
  • Para el rango C2:C6: =CONTAR.SI(cód1;C2)>0

  • Para el rango A2:A6: =CONTAR.SI(cód2;A2)>0

con esta función conseguimos determinar que elementos de un campo se repiten en el otro (en ambos casos) mediante un conteo, si se repite una o más veces entonces es claro que es un elemento duplicado.
De esta manera podemos visualizar qué elementos o registros se repiten en el campo 'Código 1' y 'Código 2'.

Elementos duplicados en campos distintos.



Ahora comenzamos con la segunda parte de la tarea: Asociar a los valores repetidos del campo 'Código 2' su correspondiente 'Descripción' asociada al campo 'Código 1'.
Por ejemplo, vemos que en el campo 'Codigo 2' existe dos valores duplicados, lo que queremos ver para cada uno de esos valores es la descripción que le corresponde, es decir, para el elemento '3' la descripción 'tres' y para el '5' la descripción 'cinco'.
Para ello aplicaremos en una columna auxiliar, en el rango D2:D6 la siguiente función:
=SI(CONTAR.SI(cód1;C2)>0;BUSCARV(C2;$A$2:$B$6;2;0);"")
en la que hacemos el mismo análisis que con el formato condicional, si el valor existe en el campo 'Código 1' realizas una búsqueda vertical sobre nuestra matriz para obtener su correspondiente descripción.

Elementos duplicados en campos distintos.

2 comentarios:

  1. Hola

    Como podría hacerlo si:

    Tengo 4 columnas con nombres de personas y quiero extraer los nombres que se repiten 3 o más veces en todas las columnas, además todas las columnas tienen diferentes tamaños de datos

    Muchas Gracias

    ResponderEliminar
    Respuestas
    1. Hola,
      con fórmulas es algo complejo... mejor emplear algo de programación.
      En breve subiré una explicación de cómo hacerlo.
      Slds

      Eliminar