jueves, 24 de junio de 2010

La función HALLAR en Excel.

Desarrollé hace algún tiempo, a petición de un usuario, un ejercicio con la función ENCONTRAR, en éste mencioné de pasada la función de la que voy a hablar hoy, la función HALLAR.

La sintaxis de la función es:
=HALLAR(texto buscado; dentro de; [comienza la búsqueda en la posición])
Las principales ventajas de esta función son que no distingue entre mayúsculas o minísculas, y permite el uso de los comodines estándar de Excel (? y * para un único caracter o una secuencia de ellos).


Veámoslo con un pequeño ejercicio en el que queremos contar cuántos elementos de una lista contienen un concepto:

La función HALLAR en Excel.


Aplicaré la siguiente función para HALLAR los productos que contengan el concepto 'HOJA'; observemos que este concepto lo encontramos escrito de diferentes maneras (Hoja, hojas, HOJA):
=HALLAR("hoja";A2;1)
obteniendo el siguiente resultado (llógicamente para aquellos productos que no encuentra nada la función nos devuelve un error #¡VALOR!):

La función HALLAR en Excel.


veámos la diferencia de resultados con la función ENCONTRAR:

La función HALLAR en Excel.


La función ENCONTRAR sólo devuelve un valor si la coincidencia es exacta en cuanto a mayúsculas y minísculas.


Sólo queda contar el número de productos que contienen el concepto buscado, para ello aplicamos la función anidada:
=ESERROR(HALLAR("hoja";A2;1))
y sobre el rango resultante, en la celda D9, haremos el conteo
=CONTAR.SI(D2:D8;"FALSO")

La función HALLAR en Excel.

13 comentarios:

  1. Interesante, MI APORTACIÓN. Se puede mejorar para que en lugar de visualizar #¡VALOR!, se muestre la celda vacía, sería así:

    =SI(ESERROR(HALLAR("hoja";A2;1));"";HALLAR("hoja";A2;1))

    ResponderEliminar
    Respuestas
    1. muchas gracias muy util

      Eliminar
  2. Gracias por el aporte Finart,
    efectivamente el método es válido para ocultar los errores, pero en este caso es precisamente el error lo que buscamos para poder contabilizar las coincidencias.
    Un saludo y muchas gracias por la aportación.

    ResponderEliminar
  3. Necesito un poco de ayuda como hago para que en una hoja busque jale los datos de otra hoja con solo buscar o poner un datos

    ResponderEliminar
  4. Hola,
    seguro que conoces la función BUSCARV, con ella podrás, en base a un valor buscado, traer los datos que necesites de cualquier otro lugar o de otra hoja.
    La sintáxis es:
    =BUSCARV(valor buscado; rango donde buscar; columna de datos a devolver; 0)
    Espero te sirva... poco más te puedo ayudar con los datos que aportas.
    Slds

    ResponderEliminar
  5. y con esa funcion de hallar/encontrar se puede hacer lo siguiente: en la columna A pongo la palabra "consig." en la B un valor correspondiente a esa palabra y en la C la funcion que evalue si dice "consig." sume una celda con otra y si no que no sume, es posible???

    ResponderEliminar
  6. Hola, buenos días.
    no sé a que celdas te refieres que sume con lo de 'una celda con otra'. Pero intuyo que necesitas algo así, en la celda C1:
    =SI(A1="consig.";B1+ ?;0)
    el interrognate es esa otra celda que quieres sumar.
    Un cordial saludo

    ResponderEliminar
  7. bueno voy a probar esa, pero entonces te lo explico completo,en la columna 'c' pongo los pagos que recibo ya sea en efectivo o consignaciones(a las consignaciones les coloco "CONSIG." y si es efectivo solo un codigo mz10-10...), en las columnas que van de la 'd' hasta la 'i' pongo el valor pagado, de la 'j' a la 'l' pongo los gastos que yo hago y en la 'm' tengo un total de los ingresos-egresos, pero yo quiero agregar otra en la 'n' que me muestre solo lo que tengo en efectivo, entonces era como: solo sumar lo que no tenga la palabra CONSIG.

    ResponderEliminar
  8. Hola,
    envíame el ejemplo a
    excelforo@gmail.com
    y le echo un vistazo
    Slds

    ResponderEliminar
  9. Hay mas ejemplos con hallar donde s eusa el +1 o -1 y el "

    ResponderEliminar
    Respuestas
    1. Hola,
      la función HALLAR plantéa una búsqueda sobre un texto a partir de la posición que indiques, en este caso 1; HALLAR empezando desde -1 te devolvería resultados anormales.
      Slds

      Eliminar
  10. quiero saber como encuentro un valor en una función si tengo lo siguiente 80=0.9*420*X(2-((420*X)/(2*30))) quiero encontrar el menor valor de x como lo hago en excel

    ResponderEliminar
    Respuestas
    1. Hola Francisco,
      para resolver ecuaciones en Excel disponemos de dos herramientas (primas hermanas) que son Buscar objetivo y Solver.

      Puedes ver un ejemplo muy similar al que planteas en:
      http://excelforo.blogspot.com.es/2010/03/raiz-de-una-ecuacion-con-buscar.html
      Slds

      Eliminar