domingo, 10 de octubre de 2010

Formato condicional aplicado a fechas.

Repasaré algunos trucos para aplicar un formato condicional aprovechando la pregunta de un lector:

...necesito me ayudes en una funcion con formatro condicional.
tengo una celda ejm A3 y una hecha de hoy por ejemplo 05-10-09 (esta fecha es de un estudio que tiene validez de un año) lo que necesito es que por ejemplo todas las fechas hasta unos 10 dias antes (la fecha de hoy 05-10-10 me salgan en blanco normal) a partir del 01-10-10 se pinte de amarillo hasta la fecha 04-10-10 y en la fecha del dia que se cumpla se pinte de rojo...


Iniciaremos nuestra construcción definiendo exactamente lo buscado, y es que para diferencias entre fechas superiores a 10 días no aplicaremos formato alguno, para diferencias entre 1 y 10 días aplicaremos un color amarillo a la celda en cuestión, y por último para fechas que hayan sobrepasado la fecha de inicio le asignaremos el color rojo.
Se trata de avisar cuándo la fecha actual ha sobrepasado alguno de los límites señalados.

Formato condicional aplicado a fechas.



Para ello aplicaremos sobre la celda de la Fecha actual los siguientes Formatos condicionales con fórmula:

Formato condicional aplicado a fechas.
haz click en la imagen



Es decir, aplicando un formato condicional para dar formato a las celdas donde las siguientes fórmulas den como resultado VERDADERO; en nuestro ejemplo, en la celda B2:
  • =$A$2-$B$2>=10 sin formato establecido.

  • =$B$2>=$A$2 con formato de fondo de la celda en rojo.

  • =Y($A$2-$B$2>0;$A$2-$B$2<=10) con formato de fondo de la celda en amarillo.

con lo que conseguimos el objetivo buscado.

13 comentarios:

  1. Hola ! tengo una plantilla de un control que me han pasado y a la cual necesitaria añadir filas y necesito saber y aprender como esta elavorada para adaptarla a mis necesidades
    no se si en algún apartado del foro se pueden colgar.

    ResponderEliminar
  2. Hola Gorvi,
    para el envío de ficheros, usa mi dirección de email:
    excelforo@gmail.com
    Slds

    ResponderEliminar
  3. Buen dia
    Necesito aplicar un formato condicional utilizando una formula utilizando fechas especificas, una fecha es 12/12/11 y la otra fecha serias 12/12/12 de lo cual quiero que 60 dias antes de llegar a la segunda fecha se cambien en color amarillo y cuando llegue los 30 dias antes de la fecha limite se torne rojo. me puedes explicar mas detalladamente la formula, ya que quise aplicar el ejemplo que ponen pero no funciona.

    gracias por tu ayuda

    ResponderEliminar
  4. Buenos días,
    la clave está en comparar tu fecha 12/12/12 (es la fecha límite) con la fecha del día, para lo que usamos la función HOY().
    Como se explica en el ejemplo, si la diferencia de días entre HOY() y la fecha límite que marcas (12/12/12) está entre 30 y 60 tengamos un formato amarillo, y si esa diferenfia es menor o igual que 30 entonces le damos un formato rojo...
    Slds

    ResponderEliminar
  5. HOLA Mmmm ME GUSTARIA SABER SI SE PUEDE APLICAR FORMATO CONDICIONAL A LAS FECHAS?????????????

    ResponderEliminar
    Respuestas
    1. Hola,
      si claro, en el fondo una fecha es un número, asi que dependiendo de qué condición necesites deberás emplear una fórmula u otra.
      Si te falla escribiendo directamente la fecha (3/11/2012), prueba empleando la función FECHA(2012;11;3).
      Slds

      Eliminar
  6. Buenas tardes, Tengo un archivo donde registro fecha de entrenamientos y sus horas, mi pregunta es como puedo contar o sumar las horas entrenadas para el mes de junio por ejemplo.

    ResponderEliminar
    Respuestas
    1. Hola Alfonso,
      podrías emplear la función SUMAR.SI.CONJUNTO sobre el campo de horas, condicionado al mes; por ejemplo:
      =SUMAR.SI.CONJUNTO(horas;meses;">=01/06/2013";meses;"<30/06/2013")

      Espero te sirva.
      Un cordial saludo

      Eliminar
  7. HOLAAA. YO TENGO UN PROBLEMA. SI TENGO UNA FECHA Y DE ESA FECHA PASADOS 5 DIAS QUIERO QUE DIGA EXPIRADO O QUE TENGA COLOR ROJO COMO HAGO Y SI TODAVIA NO HAN PASADO 5 DÍAS QUE QUEDE COMO VIGENTE O COLOR VERDE

    ResponderEliminar
    Respuestas
    1. Hola,
      serían dos cosas diferentes.
      Una primera para que te ponga 'Expirado' en otra celda adyacente necesitas un condicional que te compare con el día actual:
      =SI(HOY()=fecha+5
      2- formato fondo verde (vigente): HOY()<fecha+5

      Espero te sirva.
      Slds
      P.D.: revisa tu teclado, parece que tienes un problema con las mayúsculas

      Eliminar
  8. Hola he copiado todos los videos que veo en internet y no doy con la clave:
    Tengo una lista de fechas y lo que quiero es que se pongan en verde las fechas que esten en un rango de 10 dias de vencer. Porfa alguien sabe en que me equivoco, mi formula es: =(C5-HOY())<=10, y o me lo marca todo incluidas fechas de meses atras o se me va al mes siguiente, gracias y saludos.

    ResponderEliminar
    Respuestas
    1. Hola Roberto,
      prueba con
      =C5>=HOY()-10
      creo es lo que buscas.
      Saludos

      Eliminar