miércoles, 17 de noviembre de 2010

Contar coincidencias entre dos rangos de datos.

Para dar respuesta a la cuestión planteada por un lector, sobre la forma de calcular el número de coincidencias:

...me gustaría saber como puedo hacer que en una columna en la que inserto los digitos 1, x o 2 dependiendo de los resultados que haya en un partido, me de los acierto que genera cada uno de los participantes.ej
jornada 1 PARTICIPANTE
1 1
1 2
1 1
2 1
2 2
X X
X X
Asi sucesivamente con el resto de los participantes, el resultado que me daria en una lista general debería de ser 5...


Para ello aplicaremos una fórmula matricial sencilla y eficaz.
Tenemos la siguiente tabla de datos:

Contar coincidencias en dos rangos de datos.


La fórmula matricial será entonces:
{=SUMA(1*(A2:A8=B2:B8))}
que evalúa las coincidencias fila a fila entre ambos rangos, que al multiplicarlos por uno pueden ser sumadas.
Realmente es como si comprobáramos para cada registro de los rangos si son iguales uno a uno, por cada fila, devolviéndonos valores de VERDADERO o FALSO; que luego procedemos a sumar para conseguir el número de VERDADEROS, i.e., el número de coincidencias para ambos rangos, cinco para nuestro ejemplo.

Contar coincidencias en dos rangos de datos.

2 comentarios: