lunes, 14 de noviembre de 2011

Matriz de constantes: una matricial para contar valores divisibles por otro dado.

De manera similar a como hicimos en una entrada anterior (Matriz de constantes: una matricial para contar valores pares), en esta ocasión, determinaremos para el mismo rango de datos, cuántos valores son divisibles por 50, para lo que emplearemos la función RESIDUO.
El listado a evaluar es:

Matriz de constantes: una matricial para contar valores divisibles por otro dado.


De la entrada anterior (ver) sabemos cómo trabajar, por lo que ahorraremos algunos pasos idénticos.
Con la función
{=SI(RESIDUO(1*EXTRAE($A2;{4;8;12;16;20;24;28;32}-3;3);50)=0;1;0)}
tendríamos un rango de 1 y 0 para cada uno de los ocho valores y cada una de las celdas del rango a estudiar A2:A11:

Matriz de constantes: una matricial para contar valores divisibles por otro dado.


Pero, nosotros queremos hacerlo sólo con una fórmula matricial, por lo que replicamos la SUMA de todos esos valores tratados, con la siguiente:
{=SUMA(SI(RESIDUO(1*EXTRAE($A$2:$A$11;{4;8;12;16;20;24;28;32}-3;3);50)=0;1;0))}
La interpretación de esta función es que con la función EXTRAE obtenemos un rango de valores (ocho por cada celda, por tanto, 80 valores), valores que son analizados con la función RESIDUO para comprobar si son o no divisibles por 50, con la función condicional SI asignamos un valor 1 a los que cumplan y 0 a los que no, finalmente nos queda sumar el resultado de ese rango para obtener el número de valores divisibles entre 50 de todos los del listado.

Matriz de constantes: una matricial para contar valores divisibles por otro dado.

No hay comentarios:

Publicar un comentario en la entrada