viernes, 13 de julio de 2012

Distribuir cuotas por meses en Excel.

Hoy explicaré como con unas fórmulas sencillas y un buen planteamiento, esto es, con una buena disposición de un informe en una hoja de cálculo de Excel, podemos distribuir un importe según las cuotas mensuales, en los meses correspondientes.
Se trata de, una vez conocido el momento inicial de compra, distribuir a lo largo de los meses siguientes, los pagos o cuotas conocidos correspondientes.

Supongamos para distintas compras conocemos en cuántas cuotas/pagos debemos hacer frente a la compra, a partir de la fecha del mes de compra.
Este ejercicio me lo propuso un lector, inicialmente con una plantilla distinta a la que voy a desarrollar. Y de eso se trata realmente, cómo podemos dirigir nuestros esfuerzos a facilitar la elaboración de nuestros cálculos. Recordad que Excel es la herramienta, nosotros los artesanos.

Veamos el planteamiento inicial (no demasiado óptimo):

Distribuir cuotas por meses en Excel.


Podemos ver que la información necsaria está toda demasiado integrada en una sóla celda, por lo que trabajar sobre esto se puede complicar. Así que la primera parte del trabajo para optimizar este informe será detallar la información necesaria, disgregando en celdas diferentes la la fecha o momento de compra, el número de cuotas pactada, la cuota total a distribuir, el cálculo de cuota mensual para cada item comprado, quedando la estructura de informe como sigue:

Distribuir cuotas por meses en Excel.


Para calcular la cuota mensual, simplemente hemos aplicado la fórmula: =SI(C3="";0;D3/C3), que basicamente divide el Total entre el número de cuotas.
En el rango F2:R2, aunque visualmente aparecen los textos 'Mes 1', 'Mes 2', etc, son realmente valores de 1 a 13, pero con un Formato de celda personalizado tipo "Mes "0. Este aspecto es importante ya que nuestra futura formulación se basará en estos valores de 1 a 13.
Por último el rango F8:R8 (en amarillo) sencillamente suma las filas 3 a 7.


Ya estamos en disposición de generar una fórmula que reconozca en qué mes corresponde la cuota mensual para cada registro, es decir, en qué mes debe iniciarse el pago de cada cuota y en qué mes debe finalizar. Para esta tarea, como indicaba al inico del post, usaremos funciones muy sencillas y conocidas, principalmente el condicional SI. Con el debido cuidado de aplicar correctamente las referencias absolutas o relativas a la formula; en la celda F3 (la primera de las celdas, desde donde copiaremos al resto) tendremos:
=SI(F$2>=$B3;SI(F$2-$B3+1<=$C3;$E3;0);0)


Podemos observar como la distribución de cuotas por meses ha resultado satisfactoria... Pero ¿cómo ha trabajado esta fórmula?.
Vemos que es un doble condicional (se podía haber planteado en uno solo) que verifica dos condiciones:
La primera que el mes en el que estamos F2 es mayor o igual al de la Fecha de compra, ya que en caso contrario el valor resultante deberá ser cero, esto significaría que aún no se ha producido la compra y no hay nada que pagar:
=SI(F$2>=$B3;xxx;0)
La segunda condición verifica que sólo obtendremos una cuota si a contar desde la Fecha de compra no hemos superado el plazo de cuotas pactadas:
SI(F$2-$B3+1<=$C3;$E3;0)

El resultado final es sencillo pero práctico, lo que demuestra que Excel puede facilitarnos el trabajo, pero siempre dependerá de nosotros el sacarle todo el jugo posible...

1 comentario: