jueves, 9 de agosto de 2012

Mostrar elementos del Eje Horizontal en un gráfico de Excel.

Hoy toca hablar de gráficos. Al hilo de una entrada anterior del blog, un lector planteaba la posibilidad de mostrar un gráfico en Excel en el que se mostraran en las etiquetas del Eje Horizontal (categorías) sólo los elementos seleccionados, asociados a un gráfico de columnas, con un color diferente al resto, disponiendo además de unas Etiquetas de datos diferenciada.
Conozcamos nuestro Origen de datos para el futuro gráfico. Se trata de un sencillo listado de clientes con su Facturación. Es a partir de esta tabla, donde añadiremos algo de funcionalidad para lograr ver un gráfico de columnas, a dos colores, según los clientes seleccionados por nosotros:

Mostrar elementos del Eje Horizontal en un gráfico de Excel.


El primer paso será construir una serie de columnas auxiliares necesarias, como siempre para engañar a Excel, donde incluir los datos oportunos para dotar a las series de datos futuras con valores, así como rellenar las Etiquetas del Eje Horizontal.
La primera parte es crear una Columna (rango C2:C11), quizá la más importante, que sirva para seleccionar aquellos clientes que queremos Mostrar en el gráfico. Esto lo haremos con una sencilla Validación de datos tipo lista, con valores Sí/No.
La siguiente columna auxiliar formulada (rango D2:D11) será la que emplearemos para conseguir nuestra Etiqueta del Eje horizontal, en este caso aplicaremos la fórmula:
=SI($C2="Sí";$A2;"")
Otra columna auxiliar (rango E2:E11) nos mostrará la Serie de datos de los clientes seleccionados; en este caso la fórmula es:
=SI($C2="Sí";$B2;"")
Y la última de nuestra columnas auxiliares mostrará la Serie de datos para los clientes no seleccionados. La fórmula para el rango F2:F11 será:
=SI($C2="Sí";"";$B2)
Veamos como queda nuestro origen de datos después de los cambios:

Mostrar elementos del Eje Horizontal en un gráfico de Excel.



Ya estamos en disposición de generar nuestro gráfico en Excel. Recordemos que se trata de conseguir un gráfico de columnas, que diferencie entre los clientes que hemos seleccionado en el rango C2:C11, con colores distintos, y donde además agregaremos Etiquetas de datos sólo a los clientes marcados.
Seleccionamos el rango D1:F11 e insertamos un gráfico tipo columnas. Probablemente nos de un gráfico 'raro', pero no nos preocupemos ahora por eso. De manera sencilla nos iremos a las Herramientas de gráfico > Diseño > Datos > Seleccionar datos.


Agregaremos dos series de datos, y también para asegurarnos las Etiquetas del eje horizontal:

Mostrar elementos del Eje Horizontal en un gráfico de Excel.


Ya terminamos, porque sólo nos queda modificar dos aspectos del Formato del gráfico para lograr esto:

Mostrar elementos del Eje Horizontal en un gráfico de Excel.


La primera modificación que afecta al Formato será Superponer las Series de datos. Seleccionamos una de las Series, presionamos el botón derecho del ratón, y marcamos Formato de la serie de datos, y en la ventana activa, llevaremos hasta el 100% la opción de Superposición de series:

Mostrar elementos del Eje Horizontal en un gráfico de Excel.


La última modificación que daremos a nuestro gráfico consiste en Agregar etiquetas de datos a la Serie que queremos visualizar con valores, esto es, a la de los clientes seleccionados. Para ello marcamos la Serie 'Facturado1', y desde el menú contextual que aparece tras presionar el botón derecho del ratón, marcamos Agregar etiqueta de datos. Una vez agregadas las etiquetas, las tenemos que formatear, asi que, seleccionamos estas etiquetas de valores, y damos Formato de etiquetas de datos..., buscamos el menú Número y luego Personalizado; en 'Código de formato' agregaremos el siguiente formato:
#.##0 €;-#.##0 €;#

Mostrar elementos del Eje Horizontal en un gráfico de Excel.


Y listo. Ya tenemos nuestro gráfico dispuesto. Cada vez que necesitemos modificar el gráfico, según los clientes necesarios, marcaremos con un Sí o un No las celdas validadas del rango C2:C11. Vemos el ejemplo en la imagen:

Mostrar elementos del Eje Horizontal en un gráfico de Excel.

No hay comentarios:

Publicar un comentario en la entrada