lunes, 5 de noviembre de 2012

Extraer valores de un alfanumérico y sumarlo en Excel.

Veremos una matricial que nos ayudará a poder sumar 'valores' con una parte de texto añadida, es decir, alfanuméricos.
Daré respuesta a una lectora del blog que planteaba esta cuestión:


...no se sumar una serie de números con texto,en este caso kilómetros:
789 km
589 km
698 km...

Aquí el problema es claro, y es que al contener valores numéricos junto a una parte de texto, Excel reconoce la celda como de 'texto', lo que la convierte en inoperable... es como si quisieramos sumar palabras.
Veamos el planteamiento:

Extraer valores de un alfanumérico y sumarlo en Excel.


El trabajo para llegar a obtener el sumatorio de ese rango de celdas 'de texto', consistirá en primer lugar eliminar la parte de texto, que coincide en todas nuestras celdas con ' km'. Ojo, por que estamos eliminando también el espacio en blanco entre el número y el texto 'km'.
Lo que quede de esa eliminación, que conseguimos con la función SUSTITUIR, la convertimos en número, aplicándole la función VALOR. Al resultado numérico obtenido ya es posible aplicarle la función SUMA.
Si trabajamos sobre todo el rango al tiempo, de forma matricial, nuestra fórmula queda entonces:
=SUMA(VALOR(SUSTITUIR(A1:A3;" km";"")))

Extraer valores de un alfanumérico y sumarlo en Excel.


Con lo que obtenemos el resultado de sumar únicamente la parte numérica de cada cela.

2 comentarios:

  1. Hola soy Julio y yo tengo un problema parecido que quisiera ver si se puede hacer, trabajo con una lista de turnos en la que constan los turnos realizados en el mes, a la vez hay distintos tipos de turnos ej: TO= turno de 7 hs, T= turno de 24 hs, TN= turno de 18 hs. al final del mes se suman los turnos para computar las hs. mensuales. La pregunta del millon como hago para que sume todos los turnos según las letras, se podrá?

    ResponderEliminar
    Respuestas
    1. Hola,
      por lo que expones, necesitas saber cuántos turnos TO, T ó TN ha habido en el mes, por lo que parece que necesitas una función CONTAR.SI para cada turno, es decir:
      =CONTAR.SI(rango;"TO")
      =CONTAR.SI(rango;"T")
      =CONTAR.SI(rango;"TN")
      siendo 'rango' las celdas de todo el mes donde se distribuye esa codificación.
      Espero haberte entendido.
      Slds

      Eliminar