miércoles, 8 de octubre de 2014

Conciliando partidas con la función CONTAR.SI.

Muy frecuentemente, trabajando en temas de tesorería, buscamos la forma de facilitarnos el trabajo de conciliar importes... (ver ejemplo).
En el ejemplo de hoy veremos una manera de localizar importes equivalentes con la función CONTAR.SI.

Partimos de un listado de importes, con unas fechas dadas, con nuestra sencilla fórmula conseguiremos localizar aquellos importes sin conciliar (o de manera complementaria, los conciliados), con ciertas restricciones... y es que en caso de cantidades repetidas, asociaremos la conciliación a la primera encontrada.
Veamos nuestro ejemplo:

Conciliando partidas con la función CONTAR.SI.



la idea es localizar, para conciliarlas, los importes con signo contrario; por ejemplo, localizar si existe un importe con signo contrario al de la celda b2 (buscar -390).
La fórmula buscada y que resuelve nuestro problema sería (en C2):
=CONTAR.SI($B$2:B2;B2)>CONTAR.SI($B$2:$B$15;-B2)

OJO!! el primer CONTAR.SI tiene un rango corrido $B$2:B2 !!!; mientras el segundo trabajo sobre el rango completo.


Para facilitar la comprensión, anido el resultado de esta fórmula (será VERDADERO o FALSO), en un condicional.. quedando la fórmula completa:
=SI(NO(CONTAR.SI($B$2:B2;B2)>CONTAR.SI($B$2:$B$15;-B2));"conciliado";"SIN CONCILIAR")

Conciliando partidas con la función CONTAR.SI.



Podemos comprobar en las columnas auxiliares, D y E, la comparación que realizamos con los dos CONTAR.SI, y el sentido de nuestra fórmula aplicada en C2:C15 (celdas en amarillo de la imagen).
En la columna D, con la función:
CONTAR.SI($B$2:B2;B2)
conseguimos numerar las veces que se repite cada importe; mientras que con la función en la columna E:
CONTAR.SI($B$2:$B$15;-B2)
directamente vemos las veces que se repite en todo el rango cada importe...

Obviamente al comparar una y otra, fila a fila, con el operador 'mayor estricto', determinamos si el importe de cada fila tiene una contrapartida negativa; en caso contrario nos encontraríamos en la situación de un importe positivo sin contrapartida, o directamente una negativa sin importe positivo con que cuadrar.

No hay comentarios:

Publicar un comentario en la entrada