martes, 14 de julio de 2015

Gráfico de dispersión con barras de error.

Quizá pienses que es un tema más que visto... hacer un gráfico de dispersión con barras de error, pero comprobarás enseguida que con un poco de trabajo conseguirás un gráfico que presenta los aumentos o disminuciones entre puntos de nuestra serie (en color rojo o verde).
Este será nuestro gráfico final:

Gráfico de dispersión con barras de error.



Partiremos de los siguientes datos de nuestro rango A1:B18, y al que añadiremos las siguientes columnas auxiliares:


Antes de explicar el sentido de estas columnas auxiliares, detallo las fórmulas:
1- para el rango C2:C18: =SI(B3="";NOD();(B3>B2)*(A3-A2))
2- para el rango D2:D18: =(B2>B1)*(B1-B2)
por otro lado
3- para el rango E2:E18: =SI(B3="";NOD();(B3<=B2)*(A3-A2))
4- para el rango F2:F18: =(B2<B1)*(B1-B2)


Estos cuatro rangos obtenidos con las fórmulas anteriores nos servirán para representar con valores personalizados las barras de error para cada punto representado de nuestro origen de datos...
Por un lado para el caso en que crezca el valor de Y (color verde) o que decrezca (color rojo), mostrando este efecto las barras de error horizontal y verticalmente.
Nota: Recuerda que a un punto se le pueden añadir barras de error verticales y horizontales.


Los rangos C2:C18 y E2:E18, con sus fórmulas, nos sirven para representar las Barras de Error Horizontales, distinguiendo cuando haya aumento o disminución, el intervalo entres puntos de las Serie_X (rango A2:A18).
De forma similar, los rangos D2:D18 y F2:F18, con su formulación, representan mediante las Barras de Error Verticales los incrementos y decrementos de los valores de la Serie_Y.
Lo interesante es que añadiremos DOS series de datos iguales, una para representar las barras de error rojas y una segunda que muestre las barras de error verdes...


Pero vayamos al inicio para construir nuestro gráfico.
Lo primero será seleccionar el rango A1:B18 e insertar un Gráfico de dispersión.
A continuación Agregaremos una segunda serie exactamente igual, sobre los mismos datos!!:

Gráfico de dispersión con barras de error.


Los parámetros de ambas series serán:
1. Nombre de la Serie: ="SeriePPal"
Valores X de la serie: =Hoja4!$A$2:$A$18
Valores Y de la serie: =Hoja4!$B$2:$B$18
y
2. Nombre de la Serie: ="Serie2"
Valores X de la serie: =Hoja4!$A$2:$A$18
Valores Y de la serie: =Hoja4!$B$2:$B$18


Repito, necesitamos dos series iguales por que emplearemos cuatro barras de error...

Añadimos para las dos Series de datos ('SeriePPal' y 'Serie2') sus barras de error verticales y horizontales, con la configuración:
1- Dirección: Más
2- Estilo final: Sin remate

Gráfico de dispersión con barras de error.



En el siguiente paso, desde la sección Cuantía de error seleccionaremos tipo Personalizado > Especificar valor para cada una de las cuatro barras de error existentes..., de acuerdo a la codificación de los rangos auxiliares (barra_h_verde, barra_v_verde, barra_h_roja, barra_v_roja):

Gráfico de dispersión con barras de error.


Estos pasos nos han llevado a este gráfico:

Gráfico de dispersión con barras de error.



Finalmente un poco de estética, cambiando los colores de unas barras de error y otras.
Primero seleccionaremos las Barras de error horizontales (recuerda que hay dos!!) y la daremos formato, primero a las que tienden hacia la bajada:
Color: Rojo
Ancho: 1,5 pto
Tipo Inicial flecha: liso (sin flecha)
Tipo final flecha: liso (sin flecha)

y luego a las que tienden hacia la subida:
Color: Verde
Ancho: 1,5 pto
Tipo Inicial flecha: liso (sin flecha)
Tipo final flecha: liso (sin flecha)

Gráfico de dispersión con barras de error.



Repetimos la acción, seleccionando las Barras de error verticales (las dos!!), primero a las que tienden hacia la bajada:
Color: Rojo
Ancho: 1,5 pto
Tipo Inicial flecha: flecha
Tipo final flecha: liso (sin flecha)

De forma similar para las barra de error vertical que tiende hacia arriba:
Color: Verde
Ancho: 1,5 pto
Tipo Inicial flecha: liso (sin flecha)
Tipo final flecha: flecha

Gráfico de dispersión con barras de error.



Con lo que conseguimos el gráfico buscado...

No hay comentarios:

Publicar un comentario en la entrada