miércoles, 12 de agosto de 2015

Grado de avance con formato condicional.

Un asunto muy visual y bastante solicitado es visualizar el grado de avance de una magnitud, por ejemplo de las Ventas de unos comerciales respecto al objetivo o meta marcada...
En concreto, por darle una vuelta al tema, hoy configuraremos un formato condicional de tipo barras para que represente cuánto le falta al comercial para llegar a su objetivo, o bien cuánto ha sobrepasado la meta.

Grado de avance con formato condicional.



Lo primero que haremos será construir nuestra fórmula en el rango E3:E9 que mostrará el dato a reflejar en la barra del formato condicional, en concreto en la celda E3 añadimos:
=SI(C3=0;-1;C3/D3-1)
donde empleando la función SI condicional conseguimos el dato del avance.
Básicamente decimos que:
- si el dato real es cero, el dato a mostrar será -1
- en el resto de casos mostramos el resultado de: real/objetivo-1


Toca ahora aplicar el formato condicional sobre el rango formulado E3:E9.
Seleccionamos dicho rango y aplicamos un Formato condicional > Barras de datos > barras de datos azul:

Grado de avance con formato condicional.



El siguiente paso es Editar la regla de formato condicional, lo que haremos desde el Administrador de reglas.
En concreto marcaremos la opción: Mostrar solo la barra
y cambiaremos el 'Tipo' y 'Valor' de la barra más corta y barra más larga a Tipo: número y Valores:-1 y 1 respectivamente:
Barra más corta:
Tipo: Número
Valor: -1

Barra más larga:
Tipo: Número
Valor: 1

Grado de avance con formato condicional.


Para finalizar presionaremos el botón Valor negativo y eje..., lo que nos abrirá una nueva ventana diálogo ('Valor negativo y Configuración de eje'), donde en la sección 'Configuración de eje' marcaremos la opción: Punto medio de celda.

Grado de avance con formato condicional.



tras aceptar veremos nuestros datos como deseábamos.. con un grado de avance que se aproxima al CERO (al punto medio del eje) según llegamos al dato objetivo (lo cuál veremos en rojo), y en caso de sobrepasar el objetivo, lo veremos en azul, creciente...
En este ejemplo limitados en cuanto a rebase del objetivo en el doble...

No hay comentarios:

Publicar un comentario en la entrada