jueves, 12 de noviembre de 2015

Contando registros en columnas alternas según columna impar.

Hace pocos días una lectora planteaba una cuestión sobre cómo calcular el número de registros en un rango que verifican dos condiciones diferentes.
...Estoy utilizando esta formula:
=CONTAR.SI(K2:AA2,">0")
pero el tema es que solo necesito que lo haga en las columnas intermedias
K2, M2, O2, Q2 etc...


La primera idea podría llevarnos a emplear la función CONTAR.SI.CONJUNTO que inicialmente nos haría pensar reúne los requisitos, contar sobre un mismo rango, aquellos valores que verifican dos criterios... el problema en el caso que nos plantea la lectora es que una de las condiciones afecta a su posición en columnas (y no al valor).

Una alternativa será emplear una fórmula matricial, que en su estructura ya se ha empleado en algunas ocasiones en ejemplos expuestos.
Se trata de conseguir dos rangos 'virtuales' de ceros y unos, uno que evalúe si el valor es mayor a 10, y el otro si la columna de cada celdas es impar.

Contando registros en columnas alternas según columna impar.



La función matricial buscada la vemos en la celda C7:
=SUMA(SI(B3:S3>10;SI(ES.IMPAR(COLUMNA(B3:S3));1)))
notemos que empleamos un doble SI matricial anidado para evaluar las dos condiciones necesarias.
Además empleamos la función ES.IMPAR sobre la función COLUMNA par conocer si la columna es IMPAR.


El resultado detallado de uno y otro rango 'virtual' lo podemos comprobar en las filas 1 y 2...

No hay comentarios:

Publicar un comentario en la entrada