martes, 23 de febrero de 2016

La función INDICE en su sintaxis de referencia.

Expondré hoy un caso habitual de búsqueda sobre diferentes opciones empleando la famosa combinación de funciones INDICE y COINCIDIR, pero esta vez empleado la segunda de sus sintaxis en forma de referencia:
=INDEX(ref, núm_fila, [núm_columna], [núm_área])
lo que nos permitirá elegir el área o rango de donde extraer la información requerida.

En definitiva, esta función INDICE en esta forma, devuelve la referencia de la celda ubicada en la intersección de una fila y de una columna determinadas; sabiendo que si la referencia se compone de rangos no adyacentes, podremos elegir el rango donde buscar...


Partiremos de un rango de celdas que representan tres listas de precios para un mismo producto.
El objetivo es, a partir de un producto dado y una Lista de precios, obtener el importe correspondiente:



Con la información necesaria:
producto en celda F5
y Lista elegida en celda G5,
podemos construir la siguiente función:
=INDICE((B2:B5;C2:C5;D2:D5);COINCIDIR(F5;A2:A5;0);1;COINCIDIR(G5;B1:D1;0))


La clave está en el primer argumento de la función, donde vemos entre paréntesis las tres áreas de donde pretendemos recuperar el precio:
(B2:B5;C2:C5;D2:D5)

Con el primer COINCIDIR
COINCIDIR(F5;A2:A5;0)
aplicado sobre el rango A2:A5 de los códigos de los productos determinamos qué fila es la que nos interesa.

El segundo COINCIDIR será quien nos devuelva de cuál de las tres áreas (B2:B5;C2:C5;D2:D5) debemos recuperar el precio:
COINCIDIR(G5;B1:D1;0)


Lo interesante del uso de esta función, de esta forma, es que nos permitiría trabajar sobre rangos no adyacentes o discontinuos, siempre que seamos capaces de indicarle sobre qué rango queremos trabajar...

No hay comentarios:

Publicar un comentario en la entrada