martes, 12 de abril de 2016

Tabla de datos con textos.

Estamos muy habituados a emplear la herramienta de análisis de hipótesis Tabla de datos con valores numéricos.. ya que realmente es cuando más provecho sacamos de ella.

Veremos hoy un uso diferente, aprovechándonos de esta herramienta, pero recuperando datos tipo texto.. y como a partir de ella obtenemos una Tabla de referencia cruzada imposible de otras formas...



Como recordaremos todos, la Tabla de datos es una herramienta matricial que analiza la variabilidad de un resultado sobre dos variables.
La encontramos en la Ficha Datos > grupo Herramientas de datos > botón Análisis Y Si/Análisis de Hipótesis


La idea del ejemplo es, a partir de un rango de datos por columnas, con registros únicos combinados sobre el campo Producto y Comercial, recuperar el dato de la columna Cliente correspondiente, esto es, construir una tabla de referencias cruzadas de acuerdo a las variables: Producto y Comercial.

Para ello emplearemos una función BUSCARV en su modo matricial (ver).
Incluimos en la celda F3 la siguiente función:
=SI.ERROR(BUSCARV(G2&F2;ELEGIR({1\2};$B$2:$B$13&$C$2:$C$13;$D$2:$D$13);2;0);"-")
ejecutada matricialmente!! (presionando Ctrl+Mayusc+Enter)


Completamos el rango de fila superior G3:K3 con los nombres de los productos, y en el rango de columna izquierda F4:F7 con los nombres de los comerciales.
A continuación seleccionamos el rango completo F3:K7 y accedemos a la herramienta Tabla, configurándola como sigue:

Tabla de datos con textos.



El resultado es el esperado, conseguimos una tabla de referencia cruzada con elementos tipo texto en el cruce!!... algo que no conseguiríamos con tablas dinámicas, por ejemplo.

4 comentarios:

  1. Hola Ismael, otra manera de hacerlo mas sencilla.

    Aprovechamos que Excel, cuando defines un rango con una fórmula le da automáticamente forma matricial.

    Nombro los rangos de celdas de productos, comerciales y clientes como "Procucto","Comercial" y "Cliente".

    Ahora el truco de magia: defino un nuevo rango al que llamo "Mix" con la siguiente fórmula: =Producto&Comercial

    Si los datos con los productos están en G3:K3 y los de los clientes en F4:F7 como en tu ejemplo, para construir la tabla de referencias cruzadas en G2:K8 pongo la siguiente fórmula (no matricial):

    =SI.ERROR(INDICE(Cliente;COINCIDIR(G$3&$F4;Mix;0));"-")

    Un cordial saludo,

    Daniel


    ResponderEliminar
    Respuestas
    1. Muchas gracias por el aporte Daniel ;-)

      Realmente el sentido del ejercicio no era tanto la fórmula como exponer el uso de Tabla de datos.

      Un cordial saludo!!

      Eliminar
  2. Yo tengo una consulta particular, planteo la idea: Tengo X personas (por ejemplo Juan, Pedro y Pablo). Y se que cada uno de ellos hacen diferentes tareas, Juan hace las tareas A, B y C; Pedro las tareas D, E, F, G y H; y Pablo las tareas X, Y y Z. En una columna hago una "validación de datos" mediante lista con las opciones: Juan, Pedro y Pablo. Ya elegida una opción, en otra columna: lo que quiero es tener una lista que me liste las tareas de la persona que elegí, es decir ésta lista va a cambiar según la persona elegida. Es como una especie de listar datos combinado con una función SI. Espero me puedas ayudar, desde ya muchas gracias. Emanuel

    ResponderEliminar
    Respuestas
    1. Hola,
      se trataría de emplear una validación condicionada...
      puedes echar un vistazo a un ejemplo similar en:
      http://excelforo.blogspot.com.es/2009/10/ejemplo-de-doble-validacion.html
      Espero te de la idea
      Slds

      Eliminar