jueves, 7 de julio de 2016

Suma condicionada en Excel empleando el criterio O.

Una de las limitaciones de la función SUMAR.SI.CONJUNTO (a pesar de sus miles de ventajas) es que únicamente trabaja empleando el operador Y.
Hoy veremos un ejemplo de cómo, matricialmente, podemos emplear una función SUAMR.SI.CONJUNTO para acumular datos de una condición con el criterio O.

Partimos de la siguiente Tabla:



La meta es conseguir acumular los importes cuando la Región sea 'Sur' y además el color sea o bien 'Rojo' o bien 'Verde'.

Una manera indirecta de llegar al dato es aplicar dos funciones SUMAR.SI.CONJUNTO con la condición Región 'Sur' y Color 'Rojo', una (celda H7):
=SUMAR.SI.CONJUNTO(Datos[Importe];Datos[Color];G7;Datos[Región];F7)
y otra con la condición Región 'Sur' y Color 'Verde' (celda H8):
=SUMAR.SI.CONJUNTO(Datos[Importe];Datos[Color];G8;Datos[Región];F8)

finalmente en H9 sumaríamos ambas cantidades, llegando a nuestro objetivo.


Si bien, de una manera más profesional, emplearíamos la matricial (celda I4):
=SUMA(SUMAR.SI.CONJUNTO(Datos[Importe];Datos[Región];F4;Datos[Color];G4:H4))
(recuerda validarla presionando Ctrl+Mayusc+Enter).


Donde vemos cómo el argumento de criterio que corresponde al rango de Color, es el rango de celdas G4:H4 !! (o el que necesitáramos)... al ser un rango de valores, y trabajar de manera matricial, la fórmula detecta y entiende que debe aplicarse para cada una de las celdas de dicho rango.
Acabamos anidando el resultado matricial para cada valor con la función SUMA, asegurándonos el acumulado deseado.

No hay comentarios:

Publicar un comentario en la entrada