jueves, 25 de agosto de 2016

Solver y el método de multiplicación egipcio

En la entrada del blog anterior vimos/aprendimos el método ruso de multiplicación.
Hoy toca el método egipcio sobre el que se basaba aquel.

Este antiguo método egipcio, donde sólo se requiere saber sumar consiste en que para multiplicar A x B:
1-En la primera columna se escribe la serie: f(n)=2n , partiendo desde n=0 continuando mientras 2n <A. Los primeros números de la serie quedarían de la siguiente manera: 1,2,4,8...
2-En la segunda columna se escribe la serie: f(n)=2nxB, o bien f(n)=2xf(n-1) siendo f(0)=B. El resultado es el mismo y obtendremos la siguiente serie: B, 2xB, 4xB...
3-En una tercera columna se marcan las cifras de la primera columna cuya suma resulte igual a A (de mayor a menor)
4-El resultado es la suma de las cifras marcadas de la segunda columna.

Puedes leer algo más en Wikipedia


Partimos de la siguiente plantilla:

Solver y el método de multiplicación egipcio



La disposición de las fórmulas en nuestro modelo.
En C2 y en D2 el primer y segundo valor de nuestro producto.

En B4:B15 la primera parte del cálculo, cumpliendo la condición dada, para lo que insertamos la fórmula:
=SI(POTENCIA(2;A4)<$D$2;POTENCIA(2;A4);"")

En C4:C15 incorporamos como primer valor en C4 el segundo importe a multiplicar (=313) y en C5 y siguientes multiplicamos por dos el anterior:
=+C4*2


En el rango D4:D15 no añadimos nada, ya que es en este rango donde trabajará Solver.
Sí añadimos en D16 la fórmula:
=SUMAPRODUCTO(B4:B15;D4:D15)
que será la celda objetivo de nuestra herramienta Solver.
Con Solver conseguiremos que este rango D4:D15 se complete con valores 0 y 1 hasta que D16 sume el valor del segundo importe (=313).Con lo que cumpliríamos el tercer paso de los indicados al inicio del post.

Antes de configurar Solver terminamos nuestra plantilla, rellenando el rango E4:E15 con el producto:
=C4*D4
sumando todo ello en la celda E16.
Este resultado final corresponde a la suma de los importes de la segunda columna para aquellas cantidades de la primera columna cuya suma resulte igual al primer importe.


Con el método claro (más o menos) y la plantilla montada, estamos listos para configurar Solver; así pues accedemos a la Ficha Datos > Análisis > Solver:

Solver y el método de multiplicación egipcio



De manera muy sencilla definimos como celda objetivo la celda D16, con el valor 313 (el importe del segundo importe del producto).
Las celdas cambiantes que deseamos se modifiquen serán las del rango D4:D15.
Definiendo la restricción de este mismo rango D4:D15 como números binarios.


Al resolver nuestra configuración obtendremos la confirmación:

Solver y el método de multiplicación egipcio


Y el resultado plasmado en la hoja de cálculo, con el que conseguimos el producto de 13 x 313 buscado:

Solver y el método de multiplicación egipcio



Notemos como los valores de la primera columna que corresponden con los valores 1 del rango D4:D15 suman los 313 necesarios(=256+32+16+8+1)... cumpliendo la tercera condición del método.

No hay comentarios:

Publicar un comentario en la entrada