jueves, 10 de noviembre de 2016

Encontrar Desparejados con Formato Condicional

Un lector preguntaba por una manera de localizar Desparejados entre dos listados:
[...] tengo dos columnas (A y B) con valores numéricos y lo que quiero es saber si los datos que están en A, están en B, pero como un mismo valor puede repetirse varias veces, por ejemplo en A tengo 5 valores de $100 pero en B solo tengo 4 valores de $100... quiero detectar el valor que sobra, y puede que sobre o que directamente no se encuentre ese valor en la otra columna... y esto puede suceder tanto de A a B como de B a A.[...]
Tal y como se muestra en la imagen:

Encontrar Desparejados con Formato Condicional



La idea es remarcar aquellos valores en ambos listados que no tenga equivalencia en el listado contrario.. tal como planteaba el lector.
En definitiva el trabajo consistirá en realizar un conteo cruzado entre ambos listados, de tal forma que si el conteo ordenado de un elemento dentro de su propio listado es inferior al número de veces que aparezca en el listado contrario, éste tendrá su equivalente y por tanto su pareja.


Si sobre la imagen seleccionamos el rango del primer listado A2:A11, con celda activa A2, y aplicamos un Formato Condicional con la siguiente fórmula:
=NO(CONTAR.SI($A$2:$A2;A2)<=CONTAR.SI($C$2:$C$11;A2))

Encontrar Desparejados con Formato Condicional



Por otra parte seleccionamos el segundo listado C2:C11, con celda activa C2, y aplicamos un Formato Condicional con la siguiente fórmula:
=NO(CONTAR.SI($C$2:$C2;C2)<=CONTAR.SI($A$2:$A$11;C2))

Encontrar Desparejados con Formato Condicional



El efecto de estas fórmulas, empleadas en el contexto del formato condicional, es obtener un conjunto de resultados VERDADEROS(cuando esté 'Desparejado') y FALSOS (cuando tenga 'Pareja').
Podemos ver el efecto directamente en la imagen siguiente, en los rangos auxiliares (no necesarios):



Nótese el empleo del 'rango corrido', necesario para identificar el orden en cada listado de cada valor...

4 comentarios:

  1. que crack!!! muchas gracias por tomarte el trabajo de buscar la solución.

    lo voy a compartir con mis compañeros obviamente.

    saludos cordiales Ismael.

    ResponderEliminar
  2. Ingenioso sistema que me parece muy útil. Al menos en el área contable. Gran trabajo

    ResponderEliminar
    Respuestas
    1. Gracias Marcos..
      sin duda útil técnica.

      Un cordial saludo

      Eliminar