martes, 19 de septiembre de 2017

Fórmula Matricial para replicar el operador O.

Un usuario solicitaba ayuda para replicar unos cálculos donde se necesitaba emplear el operador lógico O, i.e., adicionar importes según condiciones:
[...]Tengo que hallar la edad promedio de personas que nacieron en tumbes o puno.
La fórmula que estoy utilizando es :
=+PROMEDIO.SI.CONJUNTO(G21:G91,E21:E91,"TUMBES")
pero esta solo me obtiene la edad promedio de un lugar, lo que necesito es saber que formula tendría que usar para que me salga la edad promedio de las personas que nacieron en tumbes o en puno.[...]

Fórmula Matricial para replicar el operador O.



La fórmula matricial concreta que busca el usuario sería (en la celda H12):
=PROMEDIO(SI((F17:F87="TUMBES")+(F17:F87="PUNO");H17:H87;""))
(no olvides ejecutarla presionando Ctrl+Mayusc+Enter!!!).


Para mostrar la forma de trabajar con el operador O simplificaremos el ejercicio:

Fórmula Matricial para replicar el operador O.



En este ejemplo disponemos de un campo dividido por categoría (a, b,c y d) y unos importes sobre los que operar.
La primera fórmula matricial, en la celda F2 es:
=PROMEDIO(SI((B2:B10="a")+(B2:B10="b");C2:C10;""))
que nos devolverá el promedio de los importes que correspondan exclusivamente a las categoría a y b (celda amarillas).


Otro cálculo matricial frecuente lo vemos en la celda F3:
=SUMA(SI((B2:B10="a")+(B2:B10="b");1;0))
que nos devolverá un conteo de registros, en concreto de aquellos registros que sean a o b.


Por finalizar, un tercer cálculo matricial en al celda F4:
=SUMA(SI((B2:B10="a")+(B2:B10="b");C2:C10;""))
con el que obtenemos el sumatoria de los importes correspondientes a las categorías a o b.


En respuesta a la cuestión planteada por el usuario, no es posible usar directamente PROMEDIO.SI.CONJUNTO, ya que estas funciones emplean internamente el operador lógico Y...

No hay comentarios:

Publicar un comentario