martes, 28 de noviembre de 2017

Valor máximo de las sumas de un rango

Un lector planteaba una cuestión un tanto curiosa. Deseaba conocer cuál era el valor máximo de entre las sumas de un rango de Excel.
El punto de partida es una tabla de puntuaciones sobre los gustos de tres coches distintos:

Valor máximo de las sumas de un rango



La pregunta concreta a resolver es '¿Qué coche gustó más ?'.
Se puede entender desde dos perspectivas.
¿Cuál recibió una mayor puntuación directa entre los votantes?.
La respuesta en este caso es algo más sencilla. Basta construir la siguiente matricial (recuerda ejecutarla presionando Ctrl+Mayusc+Enter):
=INDICE($C$2:$E$2;1;MIN(SI($C$3:$E$5=MAX(C3:E5);COLUMNA($A:$C);MAX(C3:E5)+1)))

Valor máximo de las sumas de un rango



Esta fórmula matricial evalúa celda por celda del rango con las puntuaciones (C3:E5) verificando si es la máxima puntuación, en cuyo caso devuelve l aposición de su columna dentro del rango (columna 1, 2 o 3).
Finalmente, basándonos en esa columna, recuperamos la marca más votada desde el encabezado de los coches (C2:E2).


Una segunda forma de entender la pregunta planteada (algo más compleja) es la que me interesa.
¿Cuál es la más votada entre las sumas de las votaciones?.
La fórmula matricial que responde esta cuestión es:
=INDICE(C2:E2;1;COINCIDIR(MAX(INDICE(C3:E3+C4:E4+C5:E5;0));C3:E3+C4:E4+C5:E5;0))

Valor máximo de las sumas de un rango



Por partes esta fórmula mostraría:
MAX(INDICE(C3:E3+C4:E4+C5:E5;0))
el valor máximo de entre las sumas.
También podríamos haber expuesto:
MAX(C3:E3+C4:E4+C5:E5)
(en ambos casos ejecutadas matricialmente!!).


En nuestro ejemplo concreto:
Ferrari 12
McLaren 15
Porsche 14
las fórmulas anteriores devuelven 15...


Posteriormente, localizamos la posición de ese 15 entre el resto de sumas con la función COINCIDIR:
COINCIDIR(MAX(INDICE(C3:E3+C4:E4+C5:E5;0));C3:E3+C4:E4+C5:E5;0)
que será un 2.

Este 2 dentro de la función INDICE final recupera el nombre del coche con una suma mayor de puntuaciones.

No hay comentarios:

Publicar un comentario