jueves, 7 de junio de 2018

Cálculo de Integral definida de Riemann

Hablaremos hoy de un método de cálculo para integrales definidas: Integral de Riemann.
Método de cálculo para integrales definidas, a partir del cual se desarrollaron otros procesos más ajustados (Integral de Lebesgue, por ejemplo).

Obviamente me centraré en la aplicación del método de cálculo empleando Excel. Otras disquisiciones se quedan para los expertos en la materia.
Puedes leer algo más en Wikipedia.


La idea general del cálculo que veremos es obtener el valor de la integral definida por aproximación, forma simple de definir la integral de una función sobre un intervalo como el área localizada bajo la curva de la función.
Y para obtener esa aproximación al área encerrada por debajo de una curva, la dividiremos en rectángulos como indica la figura siguiente.

Cálculo de Integral definida de Riemann



El área de cada rectángulo, será el producto de la función en ese punto por el ancho del intervalo, como base del rectángulo...
Es importante saber que a mayor número de divisiones de nuestra función, en rectángulos de base menor, la aproximación de nuestro cálculo será mejor.

La idea es que al tender al infinito en la división de esta función en rectángulo por debajo de la función, llegaremos con precisión al área de la función para ese intervalo... es decir al cálculo de la integral definida.


Pondremos como ejemplo de función la parábola:
f(x)=2x2
para el intervalo entre 1 y 3.

Y como primera aproximación dividiremos en 20 tramos nuestra función.

Cálculo de Integral definida de Riemann



Como primer paso dividiremos en 20 intervalos iguales nuestra función, con la fórmula en el rango B8:B28.
Introducimos en B8 como valor fijo:
1 y en particular en B9 insertamos
=B8+($C$4-$C$3)/$C$5

como se comprueba la operación simplemente responde a una sencilla división de la longitud del intervalo (entre 1 y 3) entre las 20 partes indicadas...


El siguiente paso consiste en saber qué altura tendrá el rectángulo para cada punto anterior...
Lo cual es sencillo de calcular, solo necesitamos aplicar nuestra función
f(x)=2x2
en esos puntos.
Así en el rango de celdas C8:C28 añadimos la fórmula:
=2*POTENCIA(B8;2)

Cálculo de Integral definida de Riemann



Sabiendo la altura para cada intervalo en cada punto, ya podemos calcular el área de ese rectangulo como:
área =base x altura

sabiendo que la base es la longitud en que dividimos el intervalo entre 1 y 3.

Por tanto, en el rango D8:D28 añadimos la fórmula:
=C8*($C$4-$C$3)/$C$5

Cálculo de Integral definida de Riemann



Finalmente solo nos queda sumar las diferentes áreas.. para ello es frecuente sumar nuestras áeas por doble partida (desdel punto 0 y desde el punto 1:
En la imagen vemos esa sumas, donde en la celda F2 sumamos: =SUMA(D8:D27)
y en la celda F3: =SUMA(D9:D28)
Promediando y llegando al resultado final en F4 como: =PROMEDIO(F2:F3)

Cálculo de Integral definida de Riemann



Por tanto, para el intervalo entre 1 y 3, la integral definida de la función
f(x)=2x2
nos lleva a un valor aproximado de 17,34


De hecho si tiramos de cálculo integral, la integral de
f(x)=2x2
es
f(x)=2/3 x3
si damos valor a f(x) para 1 y para 3 serán: 0,67 y 18, y por diferencias:= 18 - 0,67 = 17,33
muy próximo al dato calculado mediante el método de Riemann anterior...

No hay comentarios:

Publicar un comentario