lunes, 3 de diciembre de 2018

Pactómetro en Excel

Aquí en España se ha hecho famoso un periodista, entre otras cosas, por su obsesiva representación de opciones electorales en un gráfico, combinando una y otra vez las distintas candidaturas hasta llegar a la más lógica en cuanto a la mayoría y al sentido político.
En el post de hoy veremos como casi replicar su famosa herramienta (el 'pactómetro') empleando Excel.
Usaremos un gráfico de barras apiladas para el caso.

Veamos nuestros datos:

Pactometro en Excel



Nuestro inicio es disponer en el rango B3:F4 los nombres de los partidos y los escaños obtenidos.
Adicionalmente añadimos la suma del total de escaños del parlamento en cuestión.
Igualmente indicamos en la celda I4 el número de escaños que marca la mayoría absoluta.


Hablemos ahora de la herramienta que permitirá 'jugar' con los escaños para ver si se llega o no a esa mayoría necesaria.
En el rango B2:F2 he incorporado controles de formulario tipo casilla de verificación; recuerda que estos controles no llevan asociada programación alguna... que simplemente se controlan desde su Formato de control....
Como observaras en la imagen anterior a estos controles les hemos quitado el texto.
Su Formato de control lo configuramos indicando que su celda vinculada es precisamente la misma donde se ubica el control:

Pactometro en Excel



Para hacer invisible los resultados marcados de esos controles (devolvería VERDADERO o FALSO), seleccionaremos el rango B2:F2 y daremos un formato de celda personalizado tipo: ;;;

Pactometro en Excel



Prepararemos ahora el rango que utilizará el gráfico.
Primero los encabezados en el rango B7:F7 donde insertaremos la siguiente fórmula referida a B2:F2
=SI(B2=VERDADERO;B3&" - "&B8;"")

que básicamente nos dice que si hemos seleccionado el control de ese partido aparecerá un título compuesto por el nombre del partido y su número de escaños, y en caso contrario nada.


De forma similar en B8:F8 añadimos la fórmula:
=SI(B2=VERDADERO;B4;"")

para obtener el número de escaños si se ha marcado el partido con el control correspondiente.


En G7:G8 añadimos por diferencias el acumulado del resto de partidos no seleccionados.
En G7 el título: 'Resto', y en G8:
=G4-SUMA(B8:F8)


Ya tenemos todos los datos.
El siguiente paso consiste en seleccionar el rango A7:G8 (ojo!!) e insertar un gráfico de barras apilado.
Y luego Cambiar fila/columna desde la barra de herramienta de gráficos > pestaña Diseño > grupo Datos > botón Cambiar fila/columna
Y el gráfico quedaría así:

Pactometro en Excel



El siguiente paso es estético... mostraremos todos los partidos y cambiaremos los colores del fondo, si así lo estimamos.
Importante: La serie de 'Resto' la pondremos con color 'Sin relleno'

Le añadiremos las Etiquetas de datos, teniendo cuidado de hacer visible o mostrar para cada punto el nombre de la serie.

Pactometro en Excel



Otro paso estético es ajustar la escala del eje horizontal de 0 a 109 (máximo número de escaños para nuestro ejemplo).
Accede a Dar formato a eje > Opciones de eje > Límites mínimo y máximo.

Pactometro en Excel



Paso final: Añadimos una serie de datos más.. la que corresponde a la 'Mayoría absoluta'.
Una manera muy rápida es copiar el rango I3:I4, copiarlo y pegarlo sobre el gráfico... o bien entrando en Seleccionar datos... y Agregar una serie nueva.

Con la nueva serie incorporada, iremos a Cambiar el tipo de gráfico de la serie, llevándonos la serie al eje secundario.

Pactometro en Excel



Configuraremos la serie sin etiqueta de datos, sin relleno de fondo y engordando la línea de borde de la serie hasta conseguir un aspecto 'distinguido'.
El sentido de esta serie es resaltar dónde se encuentra la mayoría.


Importante es configurar la escala del eje horizontal secundario igual que el principal, límites mínimo y máximo a 0 y 109 respectivamente.
Una vez configurado podemos eliminar las etiqueta de ese eje.


Y como veíamos en nuestra primera imagen este es nuestro pactómetro:

Pactometro en Excel



Listo.. y a jugar!.

No hay comentarios:

Publicar un comentario