miércoles, 10 de noviembre de 2010

Gráficos de Excel a tres colores.

Me he interesado últimamente por la representación gráfica en Excel, descubriendo un mundo interesante e interminable...
En concreto hoy voy a explicar cómo conseguir representar una misma línea en tres colores diferentes.
La idea es poder visualizar, en nuestro futuro gráfico, cómo cambia de color en función al intervalo de valores previamente definidos. Veámoslo con un ejemplo sencillo.
Supongamos queremos representar la función y = x3, para ello construimos en primer lugar una tabla de datos, aplicando la función =POTENCIA(valor;3) para obtener el valor de y:

Gráficos de Excel a tres colores.


Si en este momento construyeramos nuestro gráfico tipo línea obtendríamos una línea de un único color:

Gráficos de Excel a tres colores.


Pero nuestro trabajo va un paso más allá. En función a tres intervalos definidos:
  • hasta un valor de y de -3,375 (y <= -3,375)

  • desde un valor de y de -3,375 hasta 3,375 (y >= -3,375; y <= 3,375)

  • desde valores de y >= 3,375 (y >= 3,375)

en este caso es muy importante que los límites de los intervalos coincidan entre tramos, es decir, que las desigualdades no sean estrictas.
Lo que vamos a hacer realmente es construir tres series diferentes, una para cada tramo determinado; sustituyendo éstos por el primero dado.
Para el primer tramo, en la columna C, formulamos:
=SI($B2<=-3,375;$B2;NOD())
para el segundo, en la columna D:
=SI(Y($B2>=-3,375;$B2<=3,375);$B2;NOD())
para el tercero, en la columna E:
=SI($B2>=3,375;$B2;NOD())

Como podemos observar hemos empleado una función condicional SI, para obtener un valor numérico si cumple nuestra prueba lógica (que pertenezca al intervalo definido) y un error si no lo cumple. Precisamente el error es la clave de este gráfico a colores, ya que los gráficos en Excel no representan ningún tipo de error.

Gráficos de Excel a tres colores.



Sobre el rango seleccionado (A1:A22 y C1:E22) insertamos nuestro gráfico de línea, con lo que obtendríamos:

Gráficos de Excel a tres colores.


y listo, ya tenemos nuestro gráfico a tres colores.

5 comentarios:

  1. este excel es 2007? por que no me resulta en 2003.

    ResponderEliminar
  2. Hola Rolando,
    indistintamente en cualquier versión...
    debe funcionarte también para Excel 2003, revisa cómo está construida la gráfica.
    Slds

    ResponderEliminar
  3. carlos2231710enero 08, 2013

    Buen dia. Gracias por la ayuda sin embargo me queda una consulta: cuando ya me arroja los valores de verdadero y falso, como incluyo que salgan las barras con los colores? creo una nueva serie? saludos

    ResponderEliminar
    Respuestas
    1. Hola Carlos,
      bueno realmente al seleccionar las tres columnas con las formulaciones de dato/error se generan TRES series de datos diferentes, y por tanto, con tres colores diferentes.
      ¿al replicar los pasos explicados en la entrada no te sale lo mismo???
      Un saludo

      Eliminar