lunes, 11 de abril de 2011

Contar el número de elementos únicos en un listado con funciones.

En repetidas ocasiones me han llegado consultas sobre la manera de determinar el número de elementos no repetidos en un listado, el último fue este:

...Tengo una lista con números de folios, de los cuales hay varios que se repiten, lo que quiero saber, como contabilizo la cantidad de folios, sin tomar en cuenta los folios repetidos...


El trabajo se basará en el resultado obtenido de aplicar la función FRECUENCIA sobre nuestro listado de valores. Es importante remarcar que la fución a desarrollar sólo será válida si nuestro listado no tiene celdas vacías ni de texto, esto es, únicamente es un listado de valores numéricos.
La fórmula matricial final será:
{=SUMA(SI(FRECUENCIA(A1:A8;A1:A8)>0;1))}

Para explicar paso a paso comencemos viendo nuestro pequeño listado:

Contar el número de elementos únicos en un listado con funciones


Con la función frecuencia, aplicada de forma matricial sobre el listado de valores:
{=FRECUENCIA($A$1:$A$8;$A$1:$A$8)}
obtendremos para cada elemento que aparezca en el listado el número de veces que se repite, fundamental para poder realizar el conteo final de elementos no repetidos.

Contar el número de elementos únicos en un listado con funciones


Observemos como esta función matricial indica cuántas veces aparece en nuestro listado cada valor, por ejemplo el valor 11 aparece 3 veces.
Para poder realizar el último conteo transformamos con un condicional SI esos valores en 1 y 0:

Contar el número de elementos únicos en un listado con funciones


Estos valores serán los que, sumados, nos dicen cuántas elementos únicos (sin repetición) existen en nuestro listado.
Todo esto resumido en la función matricial única:
{=SUMA(SI(FRECUENCIA(A1:A8;A1:A8)>0;1))}
que en el ejemplo devolverá un valor 6, es decir, existen 6 elemento únicos.

No hay comentarios:

Publicar un comentario en la entrada