lunes, 25 de junio de 2012

Cómo sumar letras en Excel.

Me llegó una curiosa cuestión hace pocos días sobre cómo poder sumar las letras dispuestas en un rango de celdas en Excel, conociendo su valor asociado a cada letra.
Supongamos que conocemos y tenemos dispuesta en una tabla auxiliar (A1:B7) la equivalencia Letras - Valor:


Como vemos tenemos desplegado en el rango D1:L1 de nuestra hoja de cálculo el texto excelforo, cada letra en una celda.
Si manualmente asociáramos a cada letra su valor correspondiente, como se ve en D5:L5, podríamos comprobar que la suma del texto 'excelforo' con sus valores respectivos sería igual a 35. Pero obviamente, aunque para este ejemplo sería sencillo hacerlo, pensando en trabajos algo más complejos, he desarrollado una formula matricial, que añadiremos en M1:
=SUMA(SI($A$1:$A$7=D1:L1;$B$1:$B$7))
No olvidemos validar la fórmula presionando Ctrl+Mayusc+Enter.


Lo que hemos conseguido es crear un rango de valores con el condicional:
SI($A$1:$A$7=D1:L1;$B$1:$B$7)
que busca la equivalencia entre Letra y Valor, para cada una de las celdas del rango D1:L1. Esta matriz de valores, este rango de números, acaba siendo sumado por la función SUMA, con lo que obtenemos la suma acumulada de todas esas letras.

Recordemos que lo importante de trabajar con fórmulas matriciales es ser capaces de obtener, precisamente, ese rango o matriz sobre la que operar.

2 comentarios:

  1. me sale error de la formula haciendo todos los pasos mencionados, o que cambie la funcion de formula, si pudiera mandarte mis datos please y me ayudas que no encuentro formula para hacer esa SUMA, GRACIAS

    ResponderEliminar
    Respuestas
    1. Hola Mauricio,
      asegúrate que estás ejecutando la fórmula dada matricialmente, tal como se indica...
      Si no te funcionara, puedes enviarme el fichero a
      excelforo@gmail.com
      Slds

      Eliminar