lunes, 1 de junio de 2015

Consiguiendo un objetivo con fórmulas.

Trataré hoy un caso sencillo: cómo conseguir un margen objetivo sin emplear las herramientas Buscar Objetivo ni Solver, sólo empleando fórmulas y funciones.

Esta es nuestra información de partida:



Vemos cómo con la función de Excel SUMAPRODUCTO en nuestra celda F4 hemos conseguido el margen actual global:
=SUMAPRODUCTO($C$7:$C$15;($E$7:$E$15-$D$7:$D$15))/SUMAPRODUCTO($C$7:$C$15;$D$7:$D$15)

es un margen ponderado tomando en cuenta los precios de venta, los costes y las unidades!!!.
Notemos como la función SUMAPRODUCTO al admitir operaciones matriciales, de manera interna, me permite directamente obtener la diferencia entre Precio Venta y Coste Unitario:
SUMAPRODUCTO($C$7:$C$15;($E$7:$E$15-$D$7:$D$15))


En la celda G1 vemos cuál es el margen objetivo global a alcanzar, en nuestro ejemplo 30%.

El trabajo, entonces, consiste en determinar cuáles deben ser los precios de venta para, según nuestras condiciones (costes y unidades), llegar al margen del 30%.

De igual forma, para verificar el éxito de nuestro cálculo, en la celda G4 hemos añadido una fórmula similar a la anterior, pero tomando el cuenta el nuevo Precio de Venta a calcular:
=SUMAPRODUCTO($C$7:$C$15;($G$7:$G$15-$D$7:$D$15))/SUMAPRODUCTO($C$7:$C$15;$D$7:$D$15)


El truco de la fórmula para llegar a nuestros nuevos precios de venta es muy sencillo, incrementar cada margen individual de cada artículo en el porcentaje existente entre margen actual global y margen objetivo.
En nuestro ejemplo, en las celdas G7:G15:
=(D7*(1+F7+$G$1-$F$4))



Observamos en el ejemplo como nuestro nuevo margen global coincide exactamente con el objetivo marcado.
Igualmente podríamos verificar cual es el margen individual nuevo, para el nuevo precio.. y cómo se ha comportado de forma ponderada para cada caso...

Consiguiendo un objetivo con fórmulas.

No hay comentarios:

Publicar un comentario en la entrada