miércoles, 23 de diciembre de 2015

BDEXTRAER.. otra forma de buscar información.

Hoy explicaré el uso de la función de base de datos BDEXTRAER, poco conocida, pero sin duda alguna de las más potentes en cuanto a búsqueda que nos ofrece Excel.

Como todas las funciones BD necesita un rango auxiliar donde incorporar los criterios o condiciones.
Con una sintáxis simple (e igual a todas las demás funciones BD):
=BDEXTRAER(base_datos; campo_de_donde_extraer_info; rango_criterios)


Muy importante es que debemos verificar, antes de usarla, ciertas condiciones en nuestro origen de datos:
1- OJO, por que la función extrae un único valor de nuestra base de datos cuando cumpla las condiciones especificadas.
2- Fundamental que la distribución de los datos en el origen nos aseguren, por tanto, un único valor posible como respuesta.

Notas:
+ Si ningún registro cumple los criterios, BDEXTRAER devuelve el valor de error #¡VALOR!.
+ Si más de un registro coincide con los criterios, BDEXTRAER devuelve el valor de error #¡NUM!.


Pongamos un primer ejemplo, sobre el origen de la imagen planteamos la siguiente búsqueda múltiple:

BDEXTRAER.. otra forma de buscar información.



Nuestra fórmula:
=BDEXTRAER(A1:C7;"comercial";E1:F2)
nos devuelve el 'Comercial' que coincida de manera única con los criterios de 'Zona' y 'Producto'.
Notemos la importancia de la construcción del Rango de criterios, con exactitud máxima a la hora escribir los encabezados...


Otro ejemplo, sobre una base de datos distinta...

BDEXTRAER.. otra forma de buscar información.



En este ejemplo, a modo de comparación, expongo tres formas de realizar esta búsqueda múltiple.
En la celda I3 tomando como rango de criterios las celdas de su izquierda, montamos la función de base de datos:
=BDEXTRAER(A1:D10;"Precio";F2:H3)

En la celda I7 empleamos la función SUMAR.SI.CONJUNTO apoyándonos en las celdas G7 y H7 como criterios de la suma condicionada:
=SUMAR.SI.CONJUNTO(D2:D10;A2:A10;H7;B2:B10;"<="&G7;C2:C10;">="&G7)

Finalmente en la celda I11 muestro el uso de una función matricial (recuerda validarla presionando Ctrl+mayusc+Enter):
=SUMA(SI(A2:A10=H11;SI(B2:B10<=G11;SI(C2:C10>=G11;D2:D10))))


En todos los casos, es imprescindible que se verifiquen las condiciones de partida comentadas, esto es, que la combinación de criterios de un resultado único!!

No hay comentarios:

Publicar un comentario en la entrada