jueves, 21 de julio de 2016

Contando Registros Únicos en un Rango de Excel.

Hace ya tiempo subí una explicación sobre un tema relacionado (ver.
En ese post veíamos como realizar conteos de registros únicos sobre un rango.

Hoy ampliaremos la técnica y conseguiremos contar registros únicos con varias condiciones.

Veamos nuestro rango de trabajo:

Contando Registros Únicos en un Rango de Excel.


El asunto es claro, necesitas conocer para cada fecha (01/06/2016 y 02/06/2016) con cuántos clientes únicos hemos tratado.
La función que buscamos, referenciándola a la fecha buscada (celda F3) sería:
=SUMA(SI.ERROR(1/CONTAR.SI.CONJUNTO($B$2:$B$19;$B$2:$B$19;$A$2:$A$19;F3);0))
(ejecutada matricialmente!!! - presionando Ctr+Mayusc+Enter).

Contando Registros Únicos en un Rango de Excel.



Nuestra fórmula en un primer momento realiza un conteo para cada cliente en una misma fecha, este sería su cálculo normal conseguido:

Contando Registros Únicos en un Rango de Excel.



Conseguido ese conteo realizamos y calculamos el inverso de ese valor, lo que nos otorga unas fracciones que sumadas entres sí nos devolverán el dato buscado, es decir, el número de clientes únicos por fecha:

Contando Registros Únicos en un Rango de Excel.



En nuestra fórmula matricial:
=SUMA(SI.ERROR(1/CONTAR.SI.CONJUNTO($B$2:$B$19;$B$2:$B$19;$A$2:$A$19;F3);0))
empleamos la función SI.ERROR para controlar el conteo sobre otras fechas de estudio... y que no interfieran en nuestro cálculo.

No hay comentarios:

Publicar un comentario en la entrada