martes, 26 de julio de 2016

La Función INDICE y su forma de Referencia.

Aunque no es una función muy empleada (por suerte cada vez más) la función INDICE siempre tiene guardado un as bajo la manga, y siempre nos sorprenderá.
Hoy veremos un ejemplo de la segunda sintaxis de nuestra función INDICE y su forma de referencias:
=INDICE(referencias, núm_fila, [núm_columna], [núm_área])


Veamos el siguiente planteamiento, donde se pretende recuperar un dato similar desde dos origenes diferentes.


Nuestra fórmula añadida en la celda B6 será:
=INDICE((B10:D19;E10:G19);COINCIDIR(B3;PAIS;0);COINCIDIR(B5;$B$9:$D$9;0);COINCIDIR(B4;{2014;2015};0))


Simplemente seguimos la sintaxis indicada.
Primer argumento: Referencias:= (B10:D19;E10:G19)
Notemos que se ha añadido entre paréntesis!!! (esto es importante recordarlo, en especial si los rangos son no adyacentes).
Segundo argumento: Número de fila:= Se recupera en el ejemplo apoyándonos en la función COINCIDIR:= COINCIDIR(B3;PAIS;0)
Tercer argumento: Número de columna:= igualmente y de forma similar al Número de fila, empleamos COINCIDIR:= COINCIDIR(B5;$B$9:$D$9;0)

Finalmente, cuarto argumento, una vez detectada fila y columna, nos faltaría dirigirnos a una de las dos áreas de nuestro primer argumentos: (B10:D19;E10:G19)
lo que de nuevo hacemos con el socorrido COINCIDIR sobre una constante matricial:
COINCIDIR(B4;{2014;2015};0)


El resultado es el deseado, una búsqueda sobre tres variables.

No hay comentarios:

Publicar un comentario en la entrada