jueves, 23 de febrero de 2017

Contando Únicos sobre Múltiples Criterios

Un lector consultaba por la manera de Realizar Conteos de valores únicos en base a varios criterios en Excel:
[...]Como logro con una formula recoger estos valores, que me indique el producto cuantas veces se repite según cantidad de ordenes, osea la manzana se repite en dos pedidos distintos[...]


El planteamiento del lector sería:

Contando Únicos sobre Múltiples Criterios



La fórmula matricial buscada y que soluciona el problema:
=SUMA(SI(D3=$B$2:$B$19;1/(CONTAR.SI.CONJUNTO($B$2:$B$19;D3;$A$2:$A$19;$A$2:$A$19))))
(recuerda ejecutarla matricialmente!!)


La fórmula toma una idea tradicional para contar valores distintos, que es obtener para cada registro coincidente el inverso del número total de veces que aparece esa 'múltiple' coincidencia, para a continuación sumarla y obtener un número entero que es precisamente el valor buscado.

Lo interesante de este ejercicio es el uso matricial que se hace del CONTAR.SI.CONJUNTO, y como al indicar el segundo criterio:
CONTAR.SI.CONJUNTO($B$2:$B$19;$F$3;$A$2:$A$19;$A$2:$A$19)
se emplea un rango!; así, para el ejemplo, se tendrán en cuenta todas las posibilidades que aparecen en la columna A (en el campo 'Orden').
Vemos el resultado que obtendríamos para cada registro en caso de buscar coincidencias de 'Manzana':

Contando Únicos sobre Múltiples Criterios


En el rango C2:C19 he añadido la función (extraída de la matricial anterior):
=1/(CONTAR.SI.CONJUNTO($B$2:$B$19;$F$3;$A$2:$A$19;$A$2:$A$19))
que devuelve los cocientes inversor, a partir de los cuales sumamos y obtenemos el número de coincidencias distintas.


Comprobamos el correcto funcionamiento si modificamos nuestro listado:

Contando Únicos sobre Múltiples Criterios


Observamos los tres tipos de registros asociados al elemento 'Manzana':
123 Manzana
126 Manzana
127 Manzana

Dando por buena la fórmula... y lo más interesante es que abre la puerta hacía el trabajo sobre varios campos, tantos como admita la función CONTAR.SI.CONJUNTO (hasta 127 criterios).

No hay comentarios:

Publicar un comentario