jueves, 5 de julio de 2018

Tres Formas de búsqueda condicionada

Hoy toca hablar de algo cotidiano, y repasaremos tres maneras de aplicar condiciones.
Hablaremos de:
1- función BUSCARV
2- función SI
3- función ELEGIR


Veamos un ejemplo aplicado de esto.
Supongamos tenemos las puntuaciones de varias personas (rango A1:B11), y queremos valorar esas puntuaciones de acuerdo a una tabla auxiliar (rango A15:C20):

Tres Formas de búsqueda condicionada



Aplicaremos sobre nuestra hoja de cálculo de Excel las tres funciones.
Empezaremos por el clásico BUSCARV, pero atención, en este caso emplearemos su argumento [ordenado] como VERDADERO, i.e., como una coincidencia aproximada.

Así pues en las celdas C2:C11 insertaremos la función:
=BUSCARV($B2;$A$16:$C$20;3;1)
que buscará de manera aproximada, por defecto, el número de unidades en la primera columna de nuestra tabla auxiliar de valoraciones, devolviendo el texto de 'Valoración' correspondiente.

Tres Formas de búsqueda condicionada


Primera forma fácil y elegante.

La siguiente forma emplea la función SI condicional.
En las celdas D2:D11 insertamos:
=SI($B2<10;$C$16;SI($B2<35;$C$17;SI($B2<56;$C$18;SI($B2<83;$C$19;$C$20))))
fijémosnos que anidamos un SIi dentro de otro para controlar los intervalos de la Valoración...

Tres Formas de búsqueda condicionada



Y por fin llegamos al motivo de este post, emplearemos la función ELEGIR para recuperar la Valoración que toque.
En las celdas E2:E11 añadimos:
=ELEGIR(SUMA(B2>0;B2>10;B2>35;B2>56;B2>83);$C$16;$C$17;$C$18;$C$19;$C$20)
donde lo interesante es cómo obtenemos el 'num_indice' que recupera el valor o celda de valoración que aplique por cada puntuación numérico.
La fórmula:
SUMA(B2>0;B2>10;B2>35;B2>56;B2>83)
devolverá 1,2,3,4 o 5 según la puntuación, como suma de VERDADEROS (= 1) y FALSOS (= 0)

Tres Formas de búsqueda condicionada



Por supuesto hay otra muchas maneras... sin olvidar la función (de Excel 3656) SI.CONJUNTO.

2 comentarios:

  1. Muchas gracias Ismael por este post muy interesante. La función Elegir es muy poco conocida

    ResponderEliminar
    Respuestas
    1. Gracias Juan Gabriel,
      cierto que ELEGIR es poco conocida...
      siempre es bueno tener alternativas ;-)
      Slds

      Eliminar