lunes, 20 de julio de 2009

Ejemplo para principiantes de SI anidado.

No pretendemos olvidar ni dejar de lado a aquellos usuarios con un nivel 'principiante'. Por este motivo dedicaremos diversas entradas para explicar conceptos, funciones y herramientas para ayudar a todos nuestros lectores que busquen mejorar su nivel.
En este caso ejercitaremos una de las funciones de Excel básicas, la función condicional SI, de la que ya hemos hablado en posts anteriores. Recordamos su sintaxis:
=SI(prueba_lógica;valor_si_verdadero;valor_si_falso)
Plantearemos un supuesto práctico para poder utilizar el SI, añadiendo un poco de complejidad mediante el anidado de otra función SI. Disponemos de un listado de contactos con datos que los identifican, entre otros sexo y edad; datos estos que emplearemos para anidar nuestra función SI.


disponemos a su vez de un Tabla de puntuaciones comerciales, de acuerdo a su edad y sexo, tomadas de una estadística histórica:


Para poder asociar a cada uno de nuestros contactos, a partir de este listado del que disponemos, emplearemos la función condicional SI, anidándola ya que nuestras variables son dos; la función para cada fila quedaría entonces:


donde podemos ver la manera en que queda anidado la función:
=SI(edad<50;SI(sexo="V";puntuación edad<50 & sexo V;puntuación edad<50 & sexo H);SI(sexo="V";puntuación edad>=50 & sexo V;puntuación edad>=50 & sexo H))
Es decir, nuestro SI principal nos discrimina si la edad es menor a 50, si es cierto y se cumple activamos un SI secundario, desde el que distinguimos si el sexo es V; en el caso que se cumplan ambos criterios forzamos el valor 'puntuación edad<50 & sexo V'; sin embargo si cumple la característica edad <50 y no tiene el sexo V, entonces 'puntuación edad<50 & sexo H'. Si no se cumpliera el primer condicional, y por tanto la edad tendría que ser >=50, se ejecutaría el siguiente SI secundario; sobre el que actuaría la segunda condición de sexo (al igual que el anterior SI secundario). Podríamos plantear el siguiente árbol de decisión para ver más claro nuestro planteamiento:

139 comentarios:

  1. Tengo un problema, y os pido ayuda.
    Quiero crear funcioncon SI anidada pero por lo visto supera el limite permitido y da error.

    Se trata de valores de pH. Para determinados intervalos de pH se le adjudica un numero que es una nota de calidad:
    (7-8]=1
    (6,5-7] y [8-8,5) = 2
    (6-6,5] y [8,5-9) = 3
    (5,5-6] y [9-9,5) = 4
    (4,5-5,5] y [9,5-10,5) = 5
    <=4,5 y >=10,5 = 6

    Como veis, menos en el primero, hay dos intervalos para cada nota.
    Alguien tiene una idea de como lo puedo solucionar

    muchas gracias

    Tbrsitow

    ResponderEliminar
  2. Hola,
    comentarte que en este caso no superas el límite permitido para Excel 2003 (7 SI anidados), y mucho menos para Excel 2007 (64 SI anidados); en cualquier caso he subido la solución propuesta en esta entrada
    http://excelforo.blogspot.com/2009/11/solucion-un-problema-con-vba-selectcase.html
    Espero que te sirva...
    Un saludo

    ResponderEliminar
  3. Muchas Gracias!!!

    Me habeis salvado. Haceis un trabajo increible, ayudando a pobres ignorantes de la informática como yo.

    No se porque pero tengo excel 2007 y no me dejaba utilizar más de 8 SI anidadas. Ese es el mensaje que me daba. Igual es un error del propio excel.

    gracias de nuevo

    saludos

    tbristow

    ResponderEliminar
  4. Tengo otro problema.

    Tengo 11 variables (parametros quimicos del agua)a las que se les han adjudicado una nota de calidad (de 1 a 6) y quiero que cuando 3 de esas variables (sea cual sea la variable y la combinación) supere una nota de calidad de "5", el resultado en la celda final sea de 5 también.

    Una solucion seria utilizar la formula "SI(Y" para cada combinación de 3, pero es un trabajo arduo debido a la cantidad de diferentes combinaciones que habría que hacer.

    Alguien me podria dar una solución al problema?

    Muchas gracias

    Tbristow

    ResponderEliminar
  5. Hola Tbristow,
    no termino de ver claro el problema, por favor, envíame un ejemplo a
    excelforo@gmail.com
    y trataré de darte una solución.
    Saludos

    ResponderEliminar
  6. hola necesito una ayuda de parte de ustedes tengo un campo con diferentes tipos de edades y requiero de una condición Si que me determine la cantidad de personas que tengan la edad en un determinado rango, es decir cuantas personas están en la edad de
    6-10 años
    12-20 años y demás. Les agradeceria si me pudieran ayudar...

    ResponderEliminar
  7. Que tal?
    yo probaría a emplear la función CONTAR.SI para resolver tu problema.
    Puedes ver una explicación en
    http://excelforo.blogspot.com/2009/12/funcion-contarsiconjunto-en-excel-2007.html
    Si no es lo que buscas, hazmelo saber enviándome un correo.
    Un saludo

    ResponderEliminar
  8. auxilio necesito que me ayuden a solucionar un problema como puedo tener el resultado si es de 17-18 por que no tengo ni idea

    ResponderEliminar
  9. Hola Judy,
    sólo con los datos que planteas no veo claro que pretendes hacer...
    Si lo que quieres es cosntruir un condicional para discriminar valores entre 16 y 18, deberás introducir la siguiente fórmula
    =SI(Y(A1>=16;A1<=18);"cumple";"no cumple")
    siendo la celda A1 la que deseas evaluar; y las condiciones "cumple" y "no cumple" adecuadas a lo que quieras que realice tu función.
    Slds

    ResponderEliminar
  10. Hola! Tengo un problema que no sé como resolver.
    Estoy armando una planilla de tarifas y necesito usar más de 7 funciones SI-Y anidadas en excel 2003. Probé hacerlo en el 2007 y no tengo problema, pero cuando lo quiero abrir desde otra compu que tiene instalado el 2003 no funciona mi función, valga la redundancia.
    Tengo 2 variables: Cantidad de personas y cantidad de horas. En principio serían 9 valores, de acuerdo al siguiente ejemplo:
    1 persona, 2 horas= $100
    2 personas, 2 horas= $ 130
    3 personas, 2 horas= $180
    1 persona, 3 horas= $280
    2 personas, 3 horas= $300
    3 personas, 3 horas= $350
    1 persona, 6 horas= $700
    2 personas, 6 horas= $770
    3 personas, 6 horas= $900

    Me podrían ayudar a resolverlo???
    Muchas gracias!!!

    ResponderEliminar
  11. Hola Laura,
    en Excel 2003 sólo es posible anidar hasta siete SI condicionales, tal cual planteas tu problema necesitarías alguno más. (Si trabajaras con Excel 2007 se terminaría tu pequeño problema...).
    Lo que deberás hacer es construir según se indica en este post
    http://excelforo.blogspot.com/2009/11/solucion-un-problema-con-vba-selectcase.html
    una función personalizada, en las que no tienes restricciones en cuanto al número de condicionales.
    Si tuvieras algún problema, coméntamelo.
    Slds

    ResponderEliminar
  12. Hola que tal, Como le puedo hacer para asignar a cada numero del 1 al 12, el nombre del mes.

    ResponderEliminar
  13. Hola,
    suponemos que tienes un valor de 1 a 12 en la celda A1, y en la celda B1 quieres el nombre del mes; una solución sería incluir en B1 la siguiente función:
    =ELEGIR(A1;"enero";"febrero";...;"diciembre")
    hay alguna más, pero esta es una de las más sencilla.
    Slds

    ResponderEliminar
  14. Por favor necesito de tu ayuda, no sé que fórmula ocupar.Tengo una plantilla con 100 personas y sus correspondientes edades,necesito conocer el número de personas para determinados intervalos;ejemplo de 21 a 30 años, 31 a 40 años,41 a 50,etc.No me resulto con contar si, vi tu histograma ,pero no me dio el resultado. Muchas gracias

    ResponderEliminar
  15. Hola,
    deberías mirar esta entrada donde cuento tres formas de realizar estos conteos
    http://excelforo.blogspot.com/2009/12/funcion-contarsiconjunto-en-excel-2007.html
    o bien optar por una función de Base de datos
    http://excelforo.blogspot.com/2009/07/ejercicio-funciones-de-bases-de-datos.html
    Espero te sirva... si no es así, mándame un ejemplo a
    excelforo@gmail.com
    Un saludo

    ResponderEliminar
  16. te hago una consulta ...no podes dar formato de impresion al articulo ... asi se imprimesin las publicidades y en un font de mayor tamaño?

    Gracias
    Fernando ... un agradecido seguidor de tu blog

    ResponderEliminar
  17. Hola Fernando...
    encantado de dar el formato de impresión.. pero no sé como hacerlo :-(
    Lo del tamaño de la fuente, lo subiré un punto a ver como queda...
    ¿imprimir las publicidades?????¿qué publicidad???
    Slds

    ResponderEliminar
  18. perdon .... llame publicidades a los indices de del historico del blog
    ultimos comentarios etc
    Gracias
    Fernando

    ResponderEliminar
  19. gracias me orienta mucha para empezar ahora a seguir aprendiendo..

    ResponderEliminar
  20. hola necesito una formula para =>0 k sean desparobados, =>11 k sean aprobados y =>21 k boten la palabra error o falso.---- gracias

    ResponderEliminar
  21. Hola,
    no me quedan claros tus intervalos, aunque supongo que te refieres a que por debajo de 11k estn 'desaprobados', y por encima (hasta 21k) 'aprobados'; si es así, usaríamos un doble condicional, anidando dos funciones SI:
    =SI(celda<11;"desaprobados";SI(celda<21;"aprobados";"error"))
    Espero haya acertado con los intervalos de trabajo.
    Slds

    ResponderEliminar
  22. Necesito ayuda en una formula.

    Tengo un resultado ejemplo:

    2.35
    2.45
    2.55
    2.65
    2.75
    2.85
    2.95
    3.
    3.1
    3.2

    y la pregunta es esta:

    si el alumno saca en definitiva un valor mayor de 2.85 y menor que 3.0 el computador lo debe acercar a 3.0, si saca un valor diferente a este rango se deja el valor calculado…

    He intentado pero solo logro que los valores que están entre 2.85 y 3.0 queden en 3, y también logro que los que están arriba de 3.1 no cambien su valor, pero los que están por debajo de 3.85 me aparece falso y me canse de intentarlo y no lo logre.

    Espero su ayuda, si no es mucha molestia, pero lo necesito urgente para mañana viernes 29, debo enviarlo a mas tardar 6 de la tarde.

    ResponderEliminar
  23. Hola Juan,
    hubiera sido mejor me hubieras enviado tu propuesta, para ver dónde estabas fallando.ya que por lo que parece es un ejercicio de algún curso, y supongo que se trata de aprender...
    Pero bueno, la solución podría ser:
    =SI(Y(A1>=2,85;A1<3);REDONDEAR(A1;0);A1)
    para cada valor del listado.
    Espero te sea de utilidad.
    Slds

    ResponderEliminar
  24. Este comentario ha sido eliminado por el autor.

    ResponderEliminar
  25. Este comentario ha sido eliminado por el autor.

    ResponderEliminar
  26. Necesito ayuda urgente. (si no es mucha molestia para hoy 29 de abril a mas tardar 11 PM hora colombiana).

    tengo una columna con notas definitivas, con los siguientes datos:

    4,0
    no autorizado
    3,3
    no autorizado.

    Tambien tengo una columna con los siguientes datos que representan fallas.

    4
    2
    1
    2

    La pregunta es la siguiente:

    Si el alumno saca en definitiva un valor de 3.0 aprueba parcialmente; pero, debe tener en cuenta las fallas si son mas de 4 el alumno pierde. El valor del campo debe ser “si” en color azul o “no” en color rojo.

    yo utilice esta formula

    =SI(Y(C9>=3;E9<4);"SI";"NO")

    Pero esa formula tiene un error, cuando en la columna notas definitivas hay un numero la formula funciona correctamente, pero cuando en la columna notas dice NO AUTORIZADO, la formula me funciona mal, porque el resultado que me arroja es si, cuando debería de arrojar no ya que no se cumple con la primera prueba lógica. Tampoco he podido conseguir que el SI sea de color azul y que el NO sea de color rojo.

    También tengo otro inconveniente con otra formula la cual lo intente y no logre ni siquiera acercarme.

    La pregunta es asi:

    la columna se llama estado y la pregunta es la siguiente:

    PASA, condiciones: si definitiva (columna notas definitiva del primer problema) es >=3,0 y fallas (columna fallas del primer problema) es <=3.
    PASA APROXIMADO, condiciones: si definitiva es >=2,9 y definitiva es <=3,0 y fallas es <=3.
    PIERDE POR FALLAS, condiciones: si fallas es >3.
    PIERDE, condiciones: si definitiva es <2,9.

    Esos son los 2 problemas que tengo, el primero parece sencillo, aun asi no fui capaz; y el segundo si que no tengo idea de como hacerlo.

    Agradecería su pronta respuesta, ya que es un trabajo para enviar urgente.

    Espero que la molestia no sea demasiada y gracias de antemano.

    ResponderEliminar
  27. Estoy intentando calcular con ayuda de excel la fórmula de Prantdl-Colebrok(caudales y velocidades en tuberías) es muy compleja con logaritmos, raices cuadradas y exponenciales. Realmente no he conseguido que me de cifras adecuadas. Estoy intentando pegar lo que he hecho pero no es posible. ¿Podrías orientarme?
    te estoy muy agradecido porque aprendí en tublog a utilizar solver y fue una gran ayuda. Un saludo cordial y gracias.
    Pedro

    ResponderEliminar
  28. Hola Pedro,
    puedes usar el correo:
    excelforo@gmail.com
    y enviarme lo que tengas... no entiendo de caudales y velocidades, pero a lo mejor podré ayudarte.
    Slds

    ResponderEliminar
  29. Al volver a escribir la formula para enviartela (la había repasado no sé cuantas veces) con la explicación me he dado cuenta de dónde estaba el error: eran las unidades y una celda mal puesta. Como lo he resuelto gracias a acudir a ti te quedo reconocido, como no veas. Muchas gracias por tu buena disposición y por este trabajo tan generoso.
    Un saludo.
    Pedro

    ResponderEliminar
  30. Hola Juan,
    veamos, para la primera cuestión que planteas con el problema de la nota definitiva con un valor de texto, la función que yo aplciaría sería:
    =SI(Y(definitiva>=3;NO(ESTEXTO(definitiva));fallos<4);"SI";"NO")
    Para lo segundo yo probaría con:
    =SI(Y(definitiva>=3;fallo<=3);"PASA";SI(Y(definitiva>=2,9;definitiva<3;fallo<=3);"PASA APROX";SI(fallo>3;"PIERDE POR FALLOS";SI(definitiva<2,9;"PIERDE"))))
    Ya me contaras.
    Slds

    ResponderEliminar
  31. Gracias, me funciono muy bien, la verdad nunca había esa función que pones, por eso no tenia ni idea en que estaba fallando ya que cuando eran números me quedaba bien, pero cuando era texto me daba error, muchas gracias por la ayuda.

    ResponderEliminar
  32. Hola mi nombre es lejandro. tengo este problema. Utilizo excel 2007.
    tengo dos archivos diferentes, en uno una base de datos q me envian(1), en el otro la base de datos que yo manejo(2); necesito reconocer datos segun lo siguiente:
    manejo las sig columnas:
    (archivo 1)
    RFC:AUCP691008SB9
    NOMBRE DE LA PERSONA:ALTUZAR CABRERA PATRICIA
    PARCIALIDAD: $238.30

    RFC:AUCP691008SB9
    NOMBRE DE LA PERSONA:ALTUZAR CABRERA PATRICIA
    PARCIALIDAD: $146.41

    RFC:AUCP691008SB9
    NOMBRE DE LA PERSONA:ALTUZAR CABRERA PATRICIA
    PARCIALIDAD: $136.17

    Asi vienen varias personas con diferentes descuentos.

    (archivo 2)
    RFC:AUCP691008SB9
    Código de la persona:000346
    Ciclo:01
    Nombre de la persona:ALTUZAR CABRERA PATRICIA
    Parcialidad:146.41


    RFC:AUCP691008SB9
    Código de la persona:029204
    Ciclo:02
    Nombre de la persona:ALTUZAR CABRERA PATRICIA
    Parcialidad:237.71


    RFC:AUCP691008SB9
    Código de la persona:029204
    Ciclo:03
    Nombre de la persona:ALTUZAR CABRERA PATRICIA
    Parcialidad:135.83


    aqui esta persona se repite varias veces, el codigo es el mismo y el ciclo cambia, o, ambos cambian pero nunca el rfc ni el nombre.

    lo que yo quiero saber es como encontrar esta persona del archivo 2...
    es decir, como te podras dar cuenta es la misma persona con 3 parcialidades distintas, y dos codigos distintos, a su vez los ciclos son distintos...
    como puedo buscar o encontrar a cual pertenece cada uno del ciclo..

    bueno si gustas te puedo enviar los archivos a tu correo o dime a donde los envio y como..
    muchas gracias de antemano por tu ayuda

    ResponderEliminar
  33. Hola Lejandro,
    por favor, envíame el fichero a
    excelforo@gmail.com
    lo revisaré y te contesto.
    Un saludo

    ResponderEliminar
  34. hola mi nombre es manuel,quisiera porfavor que me ayudes a crear el desarrolo del siguiente algoritmo:
    Ingresar tres notas de un alumno y mostrarlas en forma ascendente.

    ResponderEliminar
  35. Hola mi nombre es ricardo, tengo un problema he logrado obtener los resultados que deseo con el IF de la siguiente manera:

    =SI(H7>=316,67;K7)&SI(H7>=469,05;M7)&SI(H7>=761,91;P7)

    me funciona pero me muestra los tres resultados en la misma celda pero necesito que solamente me muestre uno de los resultados en la misma celda según se cumpla la condición,ademas necesito que colocarle un rango a la condicion por ejemplo (si A1 es mayor a 100 y menor 200, A1 igual a B1) podrías ayudarme, gracias

    ResponderEliminar
  36. Hola Ricardo,
    prueba con:
    =SI(H7>=316,67;SI(H7>=469,05;SI(H7>=761,91;P7);M7);K7)

    slds

    ResponderEliminar
  37. Laura osorioagosto 07, 2011

    Hola Mi nombre es laura
    Tengo este Problema...

    En un colegio el valor de la cuota es de $150, si ésta es abonada hasta el día 10 inclusive. Si la cuota se abona hasta el día 4 inclusive, se le hace un descuento del 5%.Si se abona luego del día 10, se le aplica un recargo del 5%.Completar los días del mes como serie lineal de incremento 1 y límite 31.Calcular el valor de las cuotas en los diferentes días de un mes.

    Valor Cuota 150
    MES DE JULIO
    Fecha de Pago Monto de la cuota



    Y en este problema que publicaste en que celda pongo la formula, la verdad estoy confundida muchas gracias de todas formas

    ResponderEliminar
  38. Hola Laura,
    parece que te piden varias cosas, la primera que haríamos sería colocar en el rango A1:A31 los 31 días de julio.
    Para aplicar calcular la cuota, aplicaremos en cada celda del rango B1:B31 la siguiente fórmula:
    =SI(DIA(A1)<=4;150*(1-0,05);SI(DIA(A1)<=10;150;150*(1+0,05)))
    Espero te sirva.
    Slds

    ResponderEliminar
    Respuestas
    1. Hola yo tambien estoy tratando de hacer este ejercicio y no me sale.

      Eliminar
    2. Hola Katherine,
      entiendo te refieres al problema planteado por Laura Osorio???
      si es así, la fórmula aportada es la solución...
      En otro caso, ¿cuál es el ejercicio que no te sale y qué has intentado?

      Necesito más pistas para poder ayudarte.
      Saludos

      Eliminar
  39. Hola a todos, tengo varias cantidades en una columna, pero dependiendo dela cantidad, yo le aplico un %, es decir entre 0 y 10 1% entre 11 y 20 2%, entre 21 y 30 3%, si alguien me puede ayudar se lo agradecería mucho.
    saludos

    ResponderEliminar
  40. Hola mi nombre es Julio y agradecería me ayudaran con el siguiente problema quiero contar valores únicos pero estableciendo 2 o mas condiciones ya intente con la formula "CONTAR.SI.CONJUNTO", "SUMA(SI(", "CONTARA(FRECUENCIA", etc. de hecho ya logré que me respete las condiciones pero no puedo lograr que tome y cuente valores únicos entre duplicados.

    Agradecería mucho su ayuda!!!

    ResponderEliminar
  41. Hola Julio,
    no das muchos datos sobre cómo están estrucuturados tus datos, pero echa un vistazo a
    http://excelforo.blogspot.com/2011/04/contar-el-numero-de-elementos-unicos-en.html

    quizá te oriente.
    Slds

    ResponderEliminar
  42. Hola, la fórmula que buscas sería alg así:
    =SI(cantidad<=10%;1%;SI(Y(cantidad>10;cantidad<=20);2%;SI(cantidad>20;3%)))
    siendo 'cantidad' cada celda de la columna con datos a evaluar.
    Pruébala a ver que tal.

    Slds

    ResponderEliminar
  43. Hola a Todos,tengo una celda donde capturo cantidades, dependiendo de la cantidad se le asigna deteminado porcentaje, cómo le puedo hacer dado que los rangos que manejo son muchos, es decir entre 1 y 10 le doy el .1 %
    entre el 11 y 20 el .2 %
    entre el 21 y 30 el .3 % y así sucesivamente son como 30 rangos los que manejo.
    si alguein tiene una formaula se los agradecería mucho.
    Francisco

    ResponderEliminar
  44. Hola Francisco,
    si tienes unos intervalos correlativos, yo construiría un tabla de datos auxiliar con dos columnas, la primera donde se definan los saltos y la segunda donde poner el porcentaje que le corresponda.
    De tal forma que en la primera columna tendrías los valores 1, 11, 21, etc y en la segunda le corresponderían los porcentajes 1%, 2%, 3% etc
    Sobre esta tabla podrás aplicar la función BUSCARV con el cuarto argumento VERDADERO, es decir, coincidencia aproximada... algo así:
    =BUSCARV(valor buscado; Tabla auxiliar; 2; VERDADERO)
    Espero te sirva.
    Un saludo

    ResponderEliminar
  45. Hola buenas tardes, no me funcionó dado que las cantidades son en pesos y no se si por el signo no me funciona; para explicarme mejor, yo tengo una columna donde capturo cantidades desde 200,000.00 hasta 100,000,000.00, los rangos son
    de 200,000.00 a 300,000.00 les doy el .1 %
    de 301,000.00 a 500,000.00 les doy el .2 %
    de 501,000.00 a 1,000,000.00 le doy el .3% y así sucesivamente son 20 rangos los que manejo.
    si me pudieras ayudar te lo agradecería enormemente.
    Saludos
    Francisco.

    ResponderEliminar
  46. Hola Francisco,
    fijate que en la primera columna debes tener los valores:
    200.000
    301.000
    501.000
    etc
    en la segunda (aunque no es necesaria):
    300.000
    500.000
    1.000.000
    etc
    y en la tercera, los porcentajes correspondientes:
    1%
    2%
    3%
    el origen debe estar exactamente así construida.
    Luego podrás aplicar sobre esta tabla la función que te comentaba:
    =BUSCARV(valor buscado; Tabla auxiliar; 2; VERDADERO)
    Si sigues teniendo problemas mándame un ejemplo a
    excelforo@gmail.com

    Un saludo

    ResponderEliminar
  47. hola quisiera saber si es posible hacer una funcion si anidada con una contar si, tengo excel 2003 y cuando lo intento, me aparece una ventana diciendome que hay algo mal
    Esto es lo que he hecho:
    Se trata de una base dedatos que contiene informacion de socios deun club, datos personales, eldeporte practicado, y si adeudan la cuota, entonces con la funcion contar si quisiera contar los socios que practican el mismo deporte:

    =SI(C48="Natacion";CONTAR.SI(B5:B45;="Natacion");SI(C48="Basquetball";CONTAR.SI(B5:B45;=Basquetball);SI(C48="Handball";CONTAR.SI(B5:B45;="Handball");SI(C48="Patin Artistico";CONTAR.SI(B5:B45;="Patin Artistico");SI(C48="Futbol";CONTAR.SI(B5:B45;="Futbol"))))))

    ResponderEliminar
  48. Hola amigos:
    Soy Jose Gregorio, queria ver si me podian ayudar, tengo un cuadro control de instalaciones de camaras, en el cual coloco la fecha final de la instalacion, pero ahora quisiera poder contar aquellas instalaciones dentro de un rango de fechas es decir, instalaciones realizadas entre el 01-11-2011 y el 30-11-2011 sin necesidad de filtrar, he intentado con contar.si, pero no hayo la sintaxis correcta, me pueden ayudar??

    ResponderEliminar
  49. Hola,
    respecto a tu cuestión del Si condicionado con el CONTAR.SI, a primera vista el error es que en el segundo argumento de CONTAR.SI has añadido un igual, cuando sólo debería aparecer, en tu caso el deporte entre comillas; Esto es tu fórmula debería ser:
    =SI(C48="Natacion";CONTAR.SI(B5:B45;"Natacion");SI(C48="Basquetball";CONTAR.SI(B5:B45;"Basquetball");SI(C48="Handball";CONTAR.SI(B5:B45;"Handball");SI(C48="Patin Artistico";CONTAR.SI(B5:B45;"Patin Artistico");SI(C48="Futbol";CONTAR.SI(B5:B45;"Futbol"))))))

    Slds

    ResponderEliminar
  50. Hola José Gregorio,
    la función CONTAR.SI no sería suficiente en sí misma (se podría hacer pero es más lioso), sin emabargo, si empleas CONTAR.SI.CONJUNTO lograrás lo que quieres, ya que esta función si admite varias condiciones al tiempo.
    Sería algo así:
    =CONTAR.SI.CONJUNTO(rango fecha1;">=01/11/2011";rango fecha2;"<=30/11/2011")

    Slds

    ResponderEliminar
  51. Hola soy Francisco
    si alguien me puede ayudar con este problema se lo agradecería mucho,
    tengo estos valores.
    200,000.00
    300,000.00
    500,000.00
    600,000.00
    etc
    hasta el
    100,000,000.00
    lo que aplico o tengo que aplicar es
    entre 200,000.00 y 300,000.00 les tengo que cobrar 1232.50, entre 300,000.00 y 500,000.00 1750.00 y así hasta llegar al 100,000,000.00
    son como 20 variables;les agrdesco su atención, .
    saludos.
    Francisco

    ResponderEliminar
    Respuestas
    1. Hola Francisco,
      lo más sencillo sería construir una primera columna con los valores 200, 300, 400, ..., 100.000, y en una segunda al lado otra columna con las cantidades a cobrar 1232.50, 1750.00 etc. Supongamos columnas A y B.
      Sobre estas columnas ya podrías emplear la función BUSCARV para determinar sobre un valor buscado la cantidad correspondiente a cobrar:
      =BUSCARV(valor buscado;A:B;2;1)
      Hay alguna forma más , pero creo será suficiente la explicada.
      Slds

      Eliminar
  52. supongamos que llevamos el recuento de puestos para una funcion de cine, y que deseamos dar un descuento del 20% a los menores y que vayan a ver la "rey leon". los que vayan a ver la pelicula "matilda" tendran un descuento del 25%. el valor de laboleta es de $8500.00

    ResponderEliminar
    Respuestas
    1. Hola, que tal?...
      Supongo que tendrás en una columna A la edad del espectador y en otra columna B la película vista; asi que en otra columna C deberías aplicar la función:
      =SI(A1<18;SI(B1="rey león";8500*0.20;SI(B1="matilda";8500*0.25)))
      Con los datos aportados poco más puede ayudarte.
      Un cordial saludo

      Eliminar
  53. hola ayudenme por favor a resolver este problema, la verdad no se como...=(.....En el partido de Tres de Febrero se llevó a cabo un campeonato interbarrial de futbol. Esta es latabla con los equipos y los resultados obtenidos: RESULTADOS GRUPO 1 GOLES GRUPO 2 GOLES DEL GRUPO 1 Villa Pineral 1 Loma Hermosa 3 Villa Parque 0 Martín Coronado 0 Villa Bosch 2 Caseros 1 Ciuad Jardín 2 El Palomar 2 Pablo Podestá 0 Ciudadela 0En la columna RESULTADOS DEL GRUPO 1 debe aparecer: "Ganó" si la cantidad de goles es mayor a la del equipo del grupo 2 "Empató", si la cantidad de goles es igual a la del equipo del grupo 2 "Perdió", si la cantidad de goles es menor a la del equipo del grupo 2 5

    ResponderEliminar
    Respuestas
    1. Hola,
      no se ve claro la estructura de la tabla, pero se intuye que quieres obtener un texto 'Ganó', 'Empató' o 'Perdió' para cada partido entre equipos del grupo q y del grupo2.
      Si es así deberás añadir en la columna RESULTADO la función:
      =SI(grupo1>grupo2;"Ganó";SI(grupo1=grupo2;"Empató";"Perdió"))
      siendo grupo1 y grupo2 las celdas donde aparecen los goles para cada equipo...
      Espero orientarte.
      Slds

      Eliminar
  54. No me parece de principiantes, aun esta muy complejo..

    ResponderEliminar
  55. Hola tengo un problema con una funcion si anidada
    El ejercicio seria:
    Si el niño tiene 8 o más años y desea Equitación, se le asigna Equitación. Si el niño tiene menos de 8 años y desea Equitación, se le asigna Natación. Bajo cualquier otra circunstancia se le asigna la Actividad deseada.
    Mi propuesta sería:
    =SI(A5>=8;B5;"SI(B5=Equitación;Natación;B5)") ¿En que me equivoco?
    Aclaro que en A= edad; B= Actividad deseada

    ResponderEliminar
    Respuestas
    1. Hola Nixy,
      debería ser, ya que incluyes dos condiciones, bien:
      =SI(Y(A5>=8;B5="Equitación");"Equitación";SI(Y(A5<8;B5="Equitación");"Natación";B5))
      Pruébala y me cuentas.
      Slds

      Eliminar
  56. Gracias!!Efectivamente funcionó, pero me gustaría entender porque en la fórmula va la letra Y...
    En todos los ejemplos anteriores y en el manual de excel que poseo, no figura que haya que utilizar la letra Y.

    ResponderEliminar
    Respuestas
    1. Hola Nixy,
      bueno, la función Y exige el cumplimiento de varias condiciones simultáneamente, en tu caso, se requería que al mismo tiempo se dieran dos: mayor de 8 años y elegir Equitación...
      y emplear esa función Y soluciona el problema de manera muy sencilla.
      A veces en los manuales no está todo.
      ;-)
      Slds

      Eliminar
  57. huy muy buena sus explicaciones me la entendí y ahra puedo hacer cualquier cosa sip no hay problem gracias x tdo, gracias.

    ResponderEliminar
  58. vi sus comentarios de como otros tenian la misma tarea que yop y pues miraba sus ejemplos y le seguia sus pasos y me salia bien los ejercicios.

    ResponderEliminar
    Respuestas
    1. Hola Yolanda,
      me alegro te salieran los ejercicios basándote en las explicaciones dadas.
      Slds

      Eliminar
  59. hola queria saber si me pueden ayudar con el siguiente problema:
    tengo un cuadro de seguimiento y quiero formular para que al cumplimiento de unas fechas me salga o me pinte de rojo, amarillo o verde, otra celda.
    en que formato debo poner la fecha? como hago que cambie de color una celda segun en otra este los valores "pendiente", "realizado", o "n/a", para los dos ultimos necesito que me aparezca en otra celda el color verde, y para el primero un condicional con el tiempo que a pasado despues de la fecha de recibido, si son mas de diez dias rojo y si son menos amarillo, pendiente de la respuesta y muy agradecido por la atencion prestada

    ResponderEliminar
    Respuestas
    1. Hola,
      bueno, son muchas cosas las que pides.
      En primer lugar te recomendaría leyeras algunas entradas del post de la categoría Formato condicional.
      Allí podrás encontrar ejemplos casi idénticos a lo que quieres hacer. Se trata de crear un Formato condicional tipo fórmula, con las condiciones dadas, en tu caso con fechas.
      Del tema del cálculo de tiempo transcurrido, tendrás además que cosntruir una fórmula condicional =SI, y luego aplicarle de nuevo a esa celda un nuevo formato condicional.
      Al no dar datos de cómo tienes estructurada la hoja con los datos poco más te puedo orientar.
      Slds

      Eliminar
  60. mauro liceajunio 11, 2012

    Hola, tengo una lista de pesos de bascula que acorde a la calibración se compensan se gunel rango siguiente, de
    0 Kg - 24000 Kg - 0 Kg
    24001 Kg - 48000 Kg - 9 Kg
    48001 Kg - 60000 Kg - 19 Kg
    60001 Kg - mas - 2 Kg
    como podria aplicar la funcion SI()

    ResponderEliminar
    Respuestas
    1. Hola Mauro,
      bueno tendrías que anidar varias condiciones SI, para cubrir los cinco intervalos; hay varios ejemplos casi idénticos en el blog.
      Sería algo así:
      =SI(peso<=24000;0;SI(Y(24000<peso;peso<48000);9;SI(Y(48000<peso;peso<60000);19;2)))
      Slds

      Eliminar
  61. hola, necesito hacer 10 preguntas de logica SI de excel, pero no tengo la remota idea de como las hago, alguien me puede ayudar??

    ResponderEliminar
    Respuestas
    1. Hola yexsy,
      podrías comenzar leyendo alguno de los ejemplos que hay en el blog, incluso de los comentarios... al no dar pistas de tu ejercicio, no puedo, siquiera, orientarte un poco.
      Slds

      Eliminar
  62. Hola me puedes ayudar con este ejercicio, no sé por donde comenzar, sé que tengo que utilizar condicionales anidados pero estoy hecha un lío.

    Con la información que se le suministra a continuación se requiere que usted elabore el análisis de vencimiento y estime la provisión de cuentas incobrables al cierre del ejercicio. Para elaborar el análisis de vencimiento usted debe clasificar los montos de las facturas en cada categoría según su vencimiento según como se indica a continuación:

    Por vencer: Montos cuyo atraso (días) no supera los 30 días
    1 - 30 dias: Montos cuyo atraso (días) es mayor o igual a 1 día y menor que 31 días
    31 - 60 dias: Montos cuyo atraso (días) es mayor o igual a 31 días y menor que 61 días
    61 - 90 dias: Montos cuyo atraso (días) es mayor o igual a 61 días y menor que 91 días
    91 - > dias: Montos cuyo atraso (días) es mayor o igual a 91 días

    La provisión se estima como un porcentaje del total de la cuenta según cada categoría:

    Por vencer: 5%
    1 - 30 dias: 10%
    31 - 60 dias: 20%
    61 - 90 dias: 50%
    91 - > dias: 100%

    Nota:

    Ubique la información en dos hojas que deberá de identificar como:

    Hoja1: Análisis de vencimiento
    Hoja2: Provisión

    Luego tengo las dos tablas con fechas y días de crédito días de vencimiento y el monto en dinero.

    necesito aunque sea una idea de por donde empezar...
    AUXILIO!!!

    ResponderEliminar
    Respuestas
    1. Hola Joysmer,
      yo para obtener el análisis de vencimiento, un aging de deuda, suelo aplicar una tabla dinámica, agrupándo el campo de días vencidos manualmente en grupo de 30 días.
      Si tienes un listado con diferentes clientes y para cada cliente conoces el importe (Monto) de deuda y los días vencidos, generar una TD y te llevas el 'Importe' al área de datos y los 'Días vencidos' al área de filas o columnas, te posicionas en el campo y Agrupas como te indicaba, por 30 días.

      Para calcular la provisión sólo aplica un condicional anidado, si lo vas a hace con fórmula (o también podrías intentar una campo calculado sobre la misma TD); algo así:
      =SI(Y(0<dias;dias<=30);valor*5%;SI(Y(30<dias;dias<=50);valor*10%; ...))
      así para los cuatro grupos.

      Espero haberte orientado.
      Slds

      Eliminar
  63. Buenas, tengo una duda con esto de las preguntas anidadas en Excel 2003, y no consigo saber dónde está el fallo.
    Tengo una lista de valores (columna E) y necesito que en otra columna me aparezca el valor "High" si el valor es mayor de 70, "Medium" si está entre 10 y 70, y "Low" si el valor es menor que 10.
    Logré que me funcionara aplicando la función anidada:

    =SI(E9>70;"HIGH";SI(E9<10;"LOW";"MEDIUM"))

    Pero mi duda es que esa solución la encontré a base de darle muchas vueltas, porque mi propuesta inicial fue:

    =SI(E9>70;"High";SI(10<E9<70;"Medium";"Low"))

    y en este caso, todos los valores devueltos son "High" o "low", y realmente no sé porqué, ya que en principio las dos funciones son equivalentes desde el punto de vista lógico.

    ¿Alguna sugerencia o explicación?

    Muchas gracias de antemano ;-)

    ResponderEliminar
    Respuestas
    1. Este comentario ha sido eliminado por el autor.

      Eliminar
    2. Como te decía, conseguí que funcionara, aunque lo que no me queda claro es precisamente porqué la segunda fórmula falla.

      Ok, muchas gracias =)

      Eliminar
    3. Si, la segunda fórmula falla, por que la construcción de la segunda prueba lógica no es entendible por Excel: 10 < E9 < 70

      debería ser Y(10 < E9; E9 < 70)
      Quedando la fórmula final:
      =SI(E9 > 70;"High";SI(Y(10 < E9;E9 < 70);"Medium";"Low"))

      Perdón, pero la respuesta anterior quedó 'cortada.
      Slds

      Eliminar
  64. ¡Ahora sí que lo he entendido! No sabía que Excel no admitiera esa manera de introducir los intervalos.

    Muchas gracias, en serio.

    PD: He pinchado en todos los banners ;-)

    ResponderEliminar
    Respuestas
    1. Me alegro finalmente lo hayas comprendido, de eso trata mi blog.
      Un cordial saludo

      P.D.:Te agradezco el detalle, pero esas prácticas van contra las políticas de Google, evítalas en el futuro, ya que podrías perjudicar más que ayudar. ;-)

      Eliminar
  65. Me gustaria que me pudieran ayudar con este tema... tengo una tabla donde debo ingresar criterios de 1 al 5 en dos columnas Frecuencia y Impacto y dependiendo de la variacion de los criterios colocados me da un valor en Riesgo ejemplo. Frecuencia 1 y Impacto 5 el valor de riego es Riesgo Extremo.

    FRECUENCIA IMPACTO RIESGO

    1 1 ALTO RIESGO
    1 5 RIESGO EXTREMO
    2 1 RIESGO MODERADO

    todo esto basado en una tabla de 25 conbinaciones,
    FRECUE IMPACTO Riezgo
    1 1 ALTO RIESGO
    1 2 ALTO RIESGO
    1 3 RIESGO EXTREMO
    1 4 RIESGO EXTREMO
    1 5 RIESGO EXTREMO
    2 1 RIESGO MODERADO
    2 2 ALTO RIESGO
    2 3 ALTO RIESGO
    2 4 RIESGO EXTREMO
    2 5 RIESGO EXTREMO
    3 1 RIESGO INFERIOR
    3 2 RIESGO MODERADO
    3 3 ALTO RIESGO
    3 4 RIESGO EXTREMO
    3 5 RIESGO EXTREMO
    4 1 RIESGO INFERIOR
    4 2 RIESGO INFERIOR
    4 3 RIESGO MODERADO
    4 4 RIESGO MODERADO
    4 5 RIESGO EXTREMO
    5 1 RIESGO INFERIOR
    5 2 RIESGO INFERIOR
    5 3 RIESGO MODERADO
    5 4 ALTO RIESGO
    5 5 ALTO RIESGO

    Si utilizo la funcion si, serian mas de 7 funciones si en una sola como lo soluciono?

    ResponderEliminar
  66. la funcion si estaria hasta el 6 asi, pero despues me da error por ingreso de criterios.

    =SI(Y(C17=1;D17=1);"ALTO RIESGO";SI(Y(C17=1;D17=2);"ALTO RIESGO";SI(Y(C17=1;D17=3);"RIESGO EXTREMO";SI(Y(C17=1;D17=4);"RIESGO EXTREMO";SI(Y(C17=1;D17=5);"RIESGO EXTREMO";SI(Y(C17=2;D17=1);"RIESGO MODERADO";))))))

    ResponderEliminar
    Respuestas
    1. Hola!
      debo suponer que trabajs con Excel 2003, ya que en en versiones superiores la limitación de funciones anidadas llega hasta 64.
      Si es ese el caso tendrías que crearte una función personalizada, utilizando algo de código VBA.
      En este caso sería fácil, ya que sólo se necesita la instrucción IF THEN ELSE a modo del SI condicional que empleas en la hoja de cálculo.
      Puedes ver un ejemplo de esto en
      http://excelforo.blogspot.com.es/2010/04/if-then-multiple-condicional.html
      o también se podría aplicar la instrucción SELECT CASE, ver ejemplo en
      http://excelforo.blogspot.com.es/2009/11/solucion-un-problema-con-vba-selectcase.html

      Otra solución si utilizar VBA sería construir la tabla de 25 elementos en una tabla de referencias cruzadas (de 5 x 5) y luego usar para la búsqueda las funciones INDICE y COINCIDIR o BUSCARH
      http://excelforo.blogspot.com.es/2010/06/la-combinacion-de-coincidir-indice-e.html

      http://excelforo.blogspot.com.es/2009/12/busqueda-de-referencias-cruzadas-en.html

      Creo que la primera solución es la más sencilla para ti. De todas formas si tienes algún problema coméntamelo.
      Un cordial saludo

      Eliminar
  67. Hola me gustaría crear una función en excel 2010 que me devuelva los siguientes argumentos:

    250<=R<=700: V=8
    700<=R<=5000: V=8-7,3(1-700/R)^1,3
    5000<=R<=10000: V=2

    R lo conozco y v es el valor que quiero que en función de R obtenga automáticamente excel

    Muchas gracias

    ResponderEliminar
    Respuestas
    1. Hola,
      no se si te vale una fórmula con un SI o necesitas una función personalizada con código VBA.
      La fórmula directa de hoja de cálculo sería:
      =SI(Y(250<=celdaR;celdaR<=700);8;SI(Y(7000<celdaR;celdaR<=5000);8-7,3(1-700/celdaR)^1,3;SI(Y(5000<=celdaR;celdaR<=1000);2;"resto")))
      celdaR sería la celda que conoces...

      Slds

      Eliminar
    2. Muchas gracias por la ayuda, pero me sigue dando un error, podrias sugerirme otra forma para crear una fórmula que contenga los valores anteriores?muchisimas gracias

      Eliminar
    3. Bueno, había algún error con los ceros, pero la fórmula
      =SI(Y(250<=celdaR;celdaR<=700);8;SI(Y(700<celdaR;celdaR<=5000);8-7,3*(1-700/celdaR)^1,3;SI(Y(5000<=celdaR;celdaR<=10000);2;"resto")))
      no te puede error; en todo caso algún valor equivocado por el fallo de tipeo...
      Reemplaza celdaR por la celda que estás evaluando, y colocas la fórmula en otra celda.
      Está probada y funciona perfectamente siguiendo las indicaciones dadas.
      Slds

      Eliminar
    4. muchas gracias, ahora si funciona. Un saludo

      Eliminar
  68. Hola, buen dia, solicito su colaboracion para el siguiente caso que se trata para medir el cumplimiento en ventas de unos congeladores segun el tipo de volumen de pie, y venta minima a realizar, por ejemplo

    si el congelador es igual a 3 o 6 (pies)y la ventas es igual o mayor a 800, debe aparecer el aviso "cumple", si no como " No cumple,y sigue.
    si es igual a 7 o 8 y las ventas es igual o mayor a 1.000,"cumple".
    si es igual de 10 y tiene ventas igual o mayores a 1.200, "Cumple".
    si es igual a 11,15,o 17, y tienen ventas iguales o mayores 3.500, "cumple".
    si es igual a 18 y tiene ventas igual o mayores a 3.800,"cumple".
    si es igual a 20 y tiene ventas igual o mayores a 4.200,"cumple".
    si es igual a 44 y tiene ventas igual o mayores a 7.600,"cumple".
    y si es igual o Mayor a 69 (pies), y tiene ventas iguales o mayores a 20.000,"cumple".

    Y si ninguna de estas condiciones se cumpliera deberia salir el mensaje de " No cumple", espero que me pueda colaborar en bloq, que me parece una excelente herramienta, en que me he podido orientar.

    Muchas gracias,,

    ResponderEliminar
  69. Hola, a lo anterior comentado, la informacion la tengo ubicada de la siguiente manera
    ________________________________________
    Volumen(pie)| Venta Mes| Observacion |
    ----------------------------------------
    3 | $ 800 | Cumple
    8 | $ 900 | No cumple

    Agradezco su tiempo y colaboracion que me pueda brindar...Mil gracias.

    ResponderEliminar
    Respuestas
    1. Hola!!
      gracias por estar ahí leyéndome ;-)

      Respecto a tu problema.
      Es un poco largo escribirlo con una fórmula condicional SI; te recomendaría crear una función personalizada en VBA (muy sencillo). Puedes ver un ejemplo similar en:
      http://excelforo.blogspot.com.es/2009/11/solucion-un-problema-con-vba-selectcase.html
      o este segundo que se aproxima aún más a tu problema:
      http://excelforo.blogspot.com.es/2010/04/select-case-anidado.html

      Echa un vistazo, y si tienes algún problema, envíame un correo con ejemplo adjunto a:
      excelforo@gmail.com

      Un cordial saludo

      Eliminar
    2. Te agradecería si me podés ayudar con lo siguiente: Tengo una columna de total de ventas estimada en pesos y me piden que en la columna Resultados salga, si la venta es menor a $50000 mostrar la palabra "Bajo", si está entre $50001 y $200000 mostrar la palabra "Bueno" y si es mayor a $200000 mostrar "Muy bueno" Yo lo hice así pero no lo acepta
      SI(Y(F3<50000);"bajo";SI(Y(F3>200000);"muy bueno"; SI(Y(F3 = 50001 a 200000);"bueno";)))
      ¿me podrás orientar? Desde ya muchísimas gracias, Flavia

      Eliminar
    3. Hola Flavia,
      bueno, te fallan los paréntesis y estructurar correctamente las pruebas lógicas. Sería:
      =SI(F3<=50000;"Bajo";SI(Y(50000<F3;F3<=200000);"Bueno;"Muy bueno"))
      Slds

      Eliminar
  70. vaiacion directa ejemplo y=-4x donde x= -3,-1,0,1,3 necesito esto urgente por favor

    ResponderEliminar
    Respuestas
    1. Hola que tal??
      me alegro estés bien.
      Me encantaría poder ayudarte pero con los datos que das no sé que quieres hacer y dónde quieres llegar...???
      Un cordial saludo

      Eliminar
  71. Hola

    Necesito que alguien me ayuda con esta inquietud.

    Tengo en una celda Tipos de inventario w,z
    En otra columna % de exactitud

    Si es w entonces debo poner los siguientes rangos:

    Entre 0.5%-1% =lIGHT
    Entre 1%-3%= Serious
    Entre 3%-5%=Major
    Mayor 5% Catastrphic

    Si es Y

    Entonces

    Entre=0.5%-5%
    Entre=5%-10%
    Entre=10%-20%
    Mayor=20%


    Pero estos valores en un solo condicional:
    Lo eh intentado pero no lo logro:


    =IF(Table1[[#This Row],[Part Type]],"W",IF(AND(Table1[[#This Row],[Difference %]]>=0.5%,Table1[[#This Row],[Difference %]]<=1%),"Light",IF(AND(Table1[[#This Row],[Difference %]]>=1%,Table1[[#This Row],[Difference %]]<=3%),"Serious",IF(AND(Table1[[#This Row],[Difference %]]>=3%,Table1[[#This Row],[Difference %]]<=5%),"Major",IF(AND(Table1[[#This Row],[Difference %]]>=5%),"Catastrophic",IF(Table1[[#This Row],[Part Type]],"Y”,IF(AND(Table1[[#This Row],[Difference %]]>=0.5%,Table1[[#This Row],[Difference %]]<=5%),"Light",IF(AND(Table1[[#This Row],[Difference %]]>=5%,Table1[[#This Row],[Difference %]]<=10%,"Serious”,IF(AND(Table1[[#This Row],[Difference %]]>=10%,Table1[[#This Row],[Difference %]]<=20%),"Major",IF(AND(Table1[[#This Row],[Difference %]]>=20%),"Catastrophic","On Accuracy"))))))))))))))

    ResponderEliminar
    Respuestas
    1. Hola,
      la verdad, yo personalmente me decantaría por construir una función personalizada en VBA, mediante un SELECT CASE o un IF...THEN.
      http://excelforo.blogspot.com.es/2010/04/select-case-anidado.html.

      Pero si prefieres una función en la hoja de cálculo, para simplificar la introducción de ésta, yo haría algo así:
      =SI(Y(tipo="W";0.5%<=porc;porc<=1%);"Light";SI(Y(tipo="W";1%< porc;porc<=3%);"Serious";SI(Y(tipo="W";3%< porc;porc<=5%);"Mayor";SI(Y(tipo="W";5%<=porc);"Catastrophic";....)))))
      y continuar con las otras condiciones. De esta manera tenemos la seguridad de no olvidar ninguna condición.
      El comentario no admite tanto < ó >, lo confunde con etiquetas HTML y falla. Lo siento, pero hazte una idea...
      Slds

      Eliminar
  72. Tengo un problema, necesito una hoja de calculo que me imprima un boletin con las opciones (bajo, basico, alto, superior)

    ResponderEliminar
    Respuestas
    1. Hola, que tal?
      necesitaría que fuerass más concreto y específico, qué detallan esas opciones y cómo es el boletín, etc...
      Cordiales saludos

      Eliminar
  73. Hola excelforo, le felicito por esta importante página, que es muy constructiva para el aprendizaje, a través de los ejemplos, pude solucionar un ejercicio!! Gracias..

    att. Jenny

    ResponderEliminar
    Respuestas
    1. Muchas gracias Jenny,
      me alegro mi aportación sirva a alguien.
      Cordiales saludos

      Eliminar
  74. Oye muchas Gracias por tus comentarios fueron de Gra ayuda ahora tengo la siguinte funcion pero al parecer no funciona:

    =IF(AND(Table1[[#Headers],[IC Location]]="COBA",Table1[[#Headers],[Part Type]]="Inventory",Table1[[#Headers],[Month]]="January",Table1[[#Headers],[Week]],"W1"),AVERAGE(Table1[Severity]),0)

    Necesito que la funcion cumpla los siguientes requisitos:

    Location:COBA
    Part Type: Inventory
    Month: January
    Week: W1

    Luego, una vez cumplidas las anteriores condiciones me promedie los valores de la columnda de Severity, y me coloque el valor promedio para esas condiciones.

    Me podrias ayudar?

    Gracias

    ResponderEliminar
    Respuestas
    1. Hola,
      bueno, me alegro te sirvieran mis anteriores comentarios.

      Respecto a la cuestión que planteas, fíjate que estás 'apuntando' con tu fórmula a los encabezados (#Headers) en lugar de al campo concreto...

      REvisa la estructura,señalando los elementos correctamente.
      Te puede servir de guía el comentario anterior (4 ó por arriba de este).

      Slds

      Eliminar
  75. Hola!! revise la formula pero aun me sigue saliendo VALUE; Sin embargo no c si depronte se deba a que selecciono un rango determinado..C14:C515 y no una celda en especifico..

    =IF(AND('Cycle Count Template '!C14:C515="COBO",'Cycle Count Template '!F14:F515="Inventory",'Cycle Count Template '!G14:G515="January",'Cycle Count Template '!H14:H515="W1"),AVERAGE('Cycle Count Template '!Q14:Q515),0)

    Te encargo de tu valiosa ayuda...Gracias

    ResponderEliminar
    Respuestas
    1. Hola,
      tal cual la tienes planteada debes ejecutar esa función matricialmente para que te devuelva algún valor, esto es, en lugar de presionar Enter, debes presionar al tiempo Ctrl+Mayusc+Enter.

      Slds

      Eliminar
  76. como puedo hacer este formato, valor 952224455,formato1 (95)222-4455,formato2 (952)22 44 55,formato3 prefijo:952-numero:22 44 55

    ResponderEliminar
    Respuestas
    1. Hola, que tal, cómo estás?
      la solución es desde formato de celdas personalizado en tipo:
      Formato1:(00)000-0000
      Formato2:(000)00 00 00
      Formato3:"Prefijo:"000 - "número:" 00 00 00
      Espero te sirva
      Cordiales saludos

      Eliminar
  77. DIOS AYUDENMEN CON UN EJRCICIO

    ResponderEliminar
  78. Hola. Necesito anidar 6 condiciones distintas que si se cumplen, de el mismo resultado, pero si no se cumplen el resultado sea "blanco".

    ResponderEliminar
    Respuestas
    1. Hola,
      no sé a que 'mismo resultado' te refieres, pero el condicional tendría esta forma:
      =SI(condicion1;SI(condicion2;SI(condicion3;SI(condicion4;SI(condicion5;SI(condicion6;"mismo resultado";""))))))

      Espero te sirva.
      Slds

      Eliminar
  79. Muchas gracias. Era más o menos lo que queria, tenía un problema con la estructura...

    Un saludo

    ResponderEliminar
  80. sin embargo el resultado es FALSO ¿porqué)
    =SI(F1="44";SI(F1="77";S(IF1="88";SI(F1="66";SI(F1="88";SI(F1="DA";"433000";""))))))

    ResponderEliminar
    Respuestas
    1. Hola,
      la realidad es que el planteamiento que propones no tiene mucho sentido; si lees la fórmula es como si dijeras:
      Si es cierto que F1=44 entonces comprueba que F1=77 (!!??), y así seguirías con el resto de condiciones, ¿cómo es posible que F1 sea 44 y 77 y 88 y etc a la vez??.
      Tendrías que decir algo de este estilo:
      =SI(F1=44;"una cosa";SI(F1=77;"Otra cosa";SI(F1=88; ....
      Slds

      Eliminar
  81. lo que pretendia es que según el valor de la celda me de un resultado determinado en otro.
    No es que una celda tenga tres valores a la vez, sino que en esta celda pueda tener un valor u otro según ejecuto una macro.

    ResponderEliminar
    Respuestas
    1. En ese caso,sería mejor aplicar una función BUSCARV, sobre una tabla en la que tengas para cada valor 44,77,88 etc su cantidad/valor correspondiente.
      No hace falta macros para eso...

      Eliminar
  82. Gracias por tu respuesta.
    Un saludo

    ResponderEliminar
  83. Hola, necesito ayuda con un problema, tengo una tabla con una columna de nombres y me piden esto: Si la penúltima letra del nombre es una vocal, la ciudad es Bogotá y en caso de que sea una consonante, la ciudad es Medellín. (utilice la función SI anidada)

    ResponderEliminar
    Respuestas
    1. Hola!
      es algo largo, pero la función sería algo así (suponiendo la celda con nombre la A1):
      =SI(O(EXTRAE(A1;LARGO(A1)-1;1)="A";EXTRAE(A1;LARGO(A1)-1;1)="E";EXTRAE(A1;LARGO(A1)-1;1)="I";EXTRAE(A1;LARGO(A1)-1;1)="O";EXTRAE(A1;LARGO(A1)-1;1)="U");"Bogotá";"Medellin")

      Slds

      Eliminar
  84. HOLA, necesito me hagas el favor me ayudes ya que debo hacer lo siguiente:
    si c10>=7 y d7=1 f10*10%,si c10>=7 y d7=2 f10*5% y si c10>=7 y d7>3 f10*3%, lo hice así pero me presenta erro!!
    Gracias

    ResponderEliminar
    Respuestas
    1. Hola,
      la estructura correcta de la fución sería:
      =SI(Y(C10>=7;D7=1);F10*10%;SI(Y(C10>=7;D7=2);F10*5%;SI(Y(C10>=7;D7>=3);F10*3%)))

      Hay que prestar atención a la manera de añadir diferentes criterios y qué funciones emplear, en este caso la función Y.
      Slds cordiales

      Eliminar
  85. buenas tengo una consulta ocupo una formula que haga
    Usando las funciones Si, Y, O (Puede combinarlas como usted vea necesario) agregar una función lógica en la Celda E6 con base a lo siguiente:

    Condiciones:
    Si el saldo que se encuentra en la celda E5 está ocupado (es decir la celda tiene algún valor) Y, O bien el ingreso o el gasto registrado en la fecha 11/10/2010 está ocupado.

    Operar lo siguiente:

    Sumar el saldo de la fecha 10/10/2010 más el ingreso del 11/10/2010 y restarle el gasto registrado en la fecha 11/10/2010. De no cumplirse las condiciones la celda E6 debe quedar en blanco.

    ResponderEliminar
    Respuestas
    1. Hola Miguel,
      la cuestión es cómo tienes estructurado tu origen de datos, es decir, el gasto e ingreso por fechas dónde están...
      Te puedo dar la idea genera:
      =SI(Y(E5<>"";O(gasto<>"";ingreso<>""));saldo+ingreso-gasto;"")

      Slds

      Eliminar
  86. gracias sus explicaciones me ayudaron muxo

    ResponderEliminar
  87. necesito un ejemplo de función anidada

    ResponderEliminar
    Respuestas
    1. Hola, que tal estás¿.
      Espero te encuentres bien.

      Puedes ver un ejemplo en
      http://excelforo.blogspot.com.es/2009/10/ejemplo-de-si-doble-condicional-i.html

      o leer la explicación de esta misma entrada.

      Un cordial saludo

      Eliminar
  88. hola necesito una ayuda con excel como hago para escribir 5,10,15,20 o 30 en letras
    =SI(B12="cinco","5",SI(B12="diez","10",SI(B12="quince","15",SI(B12="veinte","20",SI(B12="treinta","30"))))+0) , ??

    ResponderEliminar
    Respuestas
    1. Hola Ander, si quieres números en letras o bien aplicas este código
      http://excelforo.blogspot.com.es/2011/11/udf-para-convertir-numeros-en-letras.html

      O bien tu fórmula (sólo para esos 5 valores) tendría que ser:
      =SI(B12=5;"cinco";SI(B12=10;"diez";SI(B12=15;"quince"; ....

      Slds

      Eliminar
  89. Una funcion logica que determine automaticamente
    El valor de la pelicula y los dias de renta.
    Tomando en cuenta el tipo que puede ser
    Estreno, normal, clasico
    con estos datos:
    tipo valor dias de renta
    estreno L. 55,00 2
    normal L. 40,00 3
    clasico L. 35,00 4

    Pelicula Tipo

    Forres gump clasico
    Avenger normal
    Superman estreno
    Despicable me II estreno
    Wolverine estreno
    Despues de la tierra normal

    ResponderEliminar
    Respuestas
    1. Hola que tal estás?, me alegra saludarte a mi también.
      lo que buscas no es una función lógica, sino una función de búsqueda, en tu caso BUSCARV, de tal forma que te relacione uno y otro rango.
      Sobre tu ejemplo, en la segunda de las tablas añadirías una primera columna para obtener el Valor:
      =BUSCARV(B2;Hoja1!A:C;2;0)
      y una segunda para los Días de renta:
      =BUSCARV(B2;Hoja1!A:C;2;0)
      siendo Hoja!A:C donde se encuentra la primera de las tablas.

      Gracias y un saludo

      Eliminar
  90. Hola, quisiera ver si me pueden ayudar. Necesito graficar en una grafica de dispersión puntos de coordenada. El problema que tengo es que a veces los puntos se repiten y no se hacen visibles en la grafica. Los valores para los puntos son del 1 al 10 para ambas columnas, pense en hacer que si el numero se repite añada decimales (0.1, 0.2, etc) para que al graficar se hagan visibles.

    ResponderEliminar
    Respuestas
    1. Hola Jorge,
      se podría hacer lo que dices, pero obviamente estarías desvirtuando el sentido de un gráfico de dispersión, que trata de presentar la nube de puntos distribuida... de acuerdo a su dispersión espacial y concentración.

      Si expones algo más en detalle del sentido del gráfico, quizá se me ocurra una solución...
      Saludos!

      Eliminar
  91. Necesito por favor me colaboren necesito calcular unas comisiones la informaciones es la siguinte
    igual 700 o menos que 899 liquidar a 25
    <699 liquidar a 20
    <=900 liquidar a 30,

    Por favor que alguien me colabore

    ResponderEliminar
    Respuestas
    1. Hola,
      claramente necesitas un condicional, pero tendrías que aclarar los intervalos...
      hay una superposición entre los que indicas....

      Slds

      Eliminar
  92. Buenas Tardes

    Por favor me podrías indicar, como hago para calcular, o como realizo una fórmula, para determinar, si un valor supera en otro en el 50%.

    Gracias, quedo atento

    ResponderEliminar
    Respuestas
    1. Hola!
      podría ser algo así:
      =SI(valor1>valor2*1.5;"valor1 supera 50% del valor2";"caso contrario")

      Espero te sirva

      Eliminar