viernes, 12 de noviembre de 2010

Gráfico de barras en Excel condicionado al valor.

Continuando con explciaciones de cómo realizar gráficos, y recordando un post que publiqué en julio de 2010 (vba formato de gráfico condicionado), en el que un usario pedía:

..referente a la posibilidad de realizar un gráfico condicional utilizando VBA.
Necesito los gáficos de barras en los que las barras sean de un color si su valor es mayor a un valor (2,4) y de otro color si su valor es menor a 2,4...


Partimos de la misma tabla de datos en la que para tres años dados disponemos de ciertos valores; trataremos de condicionar el color de la barra de acuerdo al cumplimiento o no del criterio. Para el ejemplo que solicitaba el lector, y siguiendo el razonamiento dado en una entrada del blog anterior (ver), construiremos dos series nuevas:
En la columna C formulamos:
=SI($B2 < 2.4;$B2;NOD())
y en la columna D:
=SI($B2 >= 2.4;$B2;NOD())

Si en nuestro siguiente paso seleccionamos el rango A1:A4 y C1:D4 e insertamos un gráfico de barras:

Gráfico de barras en Excel condicionado al valor.


obtendríamos un gráfico de barras a dos colores, condicionado a que cada elemento tuviera un valor inferior a 2,4.

2 comentarios:

  1. El problema de hacerlo así es que, al haber distintas series de datos, si quiero mostrar el valor de cada columna, aparece efectivamente su valor encima de la columna, pero también #N/A...

    ¿Hay algún modo de hacer que sólo aparezca el valor que existe y no #N/A?

    ¡Un saludo!

    ResponderEliminar