jueves, 16 de junio de 2011

Combinar BUSCARV con tabla dinámica.

Daré respuesta a la consulta de un usuario que necesita realizar unas agrupaciones sobre un campo de un Tabla dinámica (ver ejemplo), con la peculiaridad que los intervalos de agrupación no responden a un rango determinado:

...con una serie de datos me exigen que los agrupe en los siguientes intervalos: 0-30 30-50 50-70 70-100 100-150 150-170
y yo lo realizo creando una tabla dinámica con los datos y poniendo en rotulos de fila la superficie y en valores los empleados, y después doy a agrupar y se abre una ventana donde me dice -Empezar por: donde yo pongo 0 , y -Terminar en: donde yo pongo 30 y luego aparece -Por: y yo pongo 30. Pero aquí llega el problema ya que como todos los intervalos no tienen la misma amplitud no se como puedo realizarlo
...


Una posible solución pasaría por realizar agrupaciones manuales sobre los diferentes elementos del campo a tratar, aunque la tarea podría a llegar a ser larga y tediosa; por lo que optaré por un método 'hibrido', por el cual, incorporando una columna auxiliar a nuestro origen de datos, determinar para cada elemento del campo a estudiar a qué intervalo requerido pertenece.

Veamos el listado de datos de partida:

Combinar BUSCARV con tabla dinámica.



La primera labor consisitirá en construir una tabla auxiliar donde definir cuáles serán nuestros intervalos de trabajo:

Combinar BUSCARV con tabla dinámica.


Sobre dicha tabla auxiliar es sobre la que trabajaremos con la función BUSCARV, función de la que ya hemos hablado en varias ocasiones en este blog (ver ejemplo); la función se aplicará en una columna auxiliar anexa a nuestro origen de datos, de la siguiente forma:
=BUSCARV(B2;$E$6:$G$11;3;1)

Combinar BUSCARV con tabla dinámica.


Como podemos observar, para cada elemento, hemos asignado el intervalo requerido. La siguiente tarea es bien sencilla, ya que sólo deberemos construir o generar una tabla dinámica sobre nuestro origen de datos ampliado; en el que llevaremos nuestro nuevo campo al área de filas, y el campo 'empleados' al área de datos:

Combinar BUSCARV con tabla dinámica.


con lo que finalizaríamos nuestro ejercicio.

1 comentario:

  1. Excelente..
    He utilizado mucho esta función pero hoy aprendí más sobre el atributo "ordenado"

    ResponderEliminar